none
Cannot Get Group Policy To Change Printer Settings

    Question

  • I am using Group Policy to install printers. Under User Configuration - Preferences - Control Panel Settings - Printers, the printers are set to Update.

    On the Print Server, I made a change in the Printers Properties under the Advanced Tap - Printing Defaults and I also made the same change under the General Tab - Printing Defaults.

    I rebooted a PC but the change did not propagate down.  I let the PC sit waiting for Group Policy to process but the change still did not take.  What did I miss?

    Wednesday, November 30, 2016 5:22 PM

All replies

  • Hi,
    Please have a try to run gpupdate /force command on client, then see if the changed settings are pushed or not.
    If not, you could remove the printer from client and then apply the GPO again to check if it works.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, December 1, 2016 3:08 AM
    Moderator
  • > I am using Group Policy to install printers. Under User Configuration - Preferences - Control Panel Settings - Printers, the printers are set to Update.
     
    Local (TCP) or mapped network printer?
     
    > On the Print Server, I made a change in the Printers Properties under the Advanced Tap - Printing Defaults and I also made the same change under the General Tab - Printing Defaults.
     
    This does not work with local TCP printers on the client side.
     
    Thursday, December 1, 2016 9:18 AM
  • 1. Remove printer from client machine

    2. Update Group policy on client machine gpupdate /force command.

    3. log off and login again so that new printer will get automatically installed after you logged in (which is configured in GPO). 

    Thursday, December 1, 2016 9:39 AM
  • It's a mapped network printer.  I know removing the printer and having it re-install will work but why do we need to do that?  Group Policy should do this for us.  There are about 12 of these that will need to be done in the future...across 15 PCs or so...with multiple user accounts.  I would like to find a way to get Group Policy to do it.

    I ran gpupdate /force from an administrator command prompt and then rebooted but the setting still did not change.

    Thursday, December 1, 2016 3:58 PM
  • > It's a mapped network printer.
     
    Then make sure that on the print server, you changed the setting NOT in "printin preferences", but in "Printer properties" (one entry down in the context menu).
     
    Friday, December 2, 2016 9:31 AM
  • Yes, the change was made in Printer properties as well as Printing preferences. Now I'm beginning to wonder if instead of using Update for the action I should be using Replace. Problem with that is I'll have to leave it on Replace because I won't know when each account on each pc signs-in and has the policy run.  Or I'm wondering if maybe I need to check Run in logged-on user's security context.
    Monday, December 5, 2016 3:07 PM
  • Hi,

    For me, I would have try the replace option to see if it works.

    And we could use logoff script to remove the printers from clients, so when the user re-log in, the GPP could install the printer again and then see if the same problem occur again.

    Remove All Network Printers

    https://gallery.technet.microsoft.com/Remove-All-Network-Printers-8b82b324

    Best regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, December 8, 2016 1:41 AM
    Moderator
  • The Replace action worked.  Looks like I have to keep Replace on all the time for this printer so that other users get it when they sign on eventually.  Does this printer keep getting "Replaced" every 90 minutes or so when Group Policy refreshes?

    I have another printer in a different department where I made the same change.  This one is working with it set to Update. 

    Thursday, December 8, 2016 1:30 PM
  • Hi,

    You could select the “Apply and do not reapply” in the common tab when you configure the preference item.

    Best regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, December 12, 2016 1:38 AM
    Moderator
  • I'll give that a shot, thanks.  Would still like to hear from anyone who knows why the action Update may not be working with this device.
    Monday, December 12, 2016 4:22 PM
  • Hi,

    I am checking how the issue going, if you still have any questions, please feel free to contact us.

    And if the replies as above are helpful, we would appreciate you to mark them as answers, and if you resolve it using your own solution, please share your experience and solution here. It will be greatly helpful to others who have the same question.

    Appreciate for your feedback.

    Best regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, December 16, 2016 1:51 AM
    Moderator
  • Hello Wendy.  Setting the action to REPLACE works but it is only a work around.  It would be preferable to get this working as it should with the action UPDATE.  As such, I am waiting for someone who may know how to get it to work with UPDATE before marking something as an answer.  Thanks.
    • Edited by MIS Admin Monday, December 19, 2016 1:48 PM
    Monday, December 19, 2016 1:48 PM
  • > It would be preferable to get this working as it should with the action UPDATE.
     
    In fact it is working as it should, but your expectation differs from the developers' one :-)
     
    The action "update" only updates things you can see/configure in Group Policy Preferences Items. So for a file, e.g. it will apply "hidden" if you checked hidden in your last edit. It will NOT update the target file if the source file changes, because it ignores file metadata of the source file.
     
    For printers, GPP does not care about the underlying shared printer - it will simply ignore its metadata as well.
     
    Monday, December 19, 2016 3:52 PM
  • Hi Martin.  I'm confused why it works sometimes and worked in the past.  When I made this exact change on the print server for another printer, UPDATE pushed that change down to almost all the PCs.  In the past, whenever I made a change on the print server, UPDATE pushed it down.  All things being equal, UPDATE is not pushing the change down for the printer I started this topic about. 
    Monday, December 19, 2016 4:02 PM
  • > When I made this exact change on the print server for another printer, UPDATE pushed that change down to almost all the PCs.
     
    It is not the GPP Printer item that pushes the setting down - it is the spooler connecting to a shared network printer. And spooler issues are especially hard to troubleshoot, unfortunately :-(
    Might be a driver issue, might be some weird quirk with a port monitor or something totally different.
     
    Monday, December 19, 2016 4:35 PM
  • For Windows 10 clients, new settings will not be applied until the Windows 10 version of the core driver files are installed onto the machine sharing the printer.

    https://support.microsoft.com/en-us/kb/3201130

    Printing preferences from the print server don't synchronize in Windows 10 version 1607


    Alan Morris formerly with Windows Printing Team

    Sunday, January 1, 2017 9:21 PM
    Answerer
  • Thanks Alan, this is good to know.  Settings have been applying on my 1607 clients but my print server is 2012, not 2012 R2.  I will have to remember this if I ever bring it to R2.
    Tuesday, January 3, 2017 2:21 PM
  • Hmm, so I wonder if this will be a problem all over again when Windows 10 1703 comes out next month.
    Monday, February 27, 2017 7:23 PM
  • It looks like that KB (3201130) was recently revised. It now applies to Server 2012 Standard also.
    Tuesday, February 28, 2017 6:35 PM