Lenovo x131e freeze after mdt boot RRS feed

  • Question

  • Wondering how to troubleshoot this issue - as I am unable to get a prompt using f8.  We are just getting some units (lenovo x131e) in for testing, and image deploymen testing.  And they freeze as soon as they enter MDT (PE environment) all you can see is the background, and no mouse, no keyboard, and no command prompt.

    How can I figure out whats going on?



    Tuesday, May 14, 2013 5:59 PM

All replies

  • Have you tried a "clean" WinPE image with no additional drivers or components?  You can also, from Properties on the Deployment Share, create a "Generic Boot Image" that doesn't have any scripts.  Try to generate that ISO and boot a machine from that.  Might give us an idea of where the problem is if one of those works but the other doesn't.

    David Coulter | | @DCtheGeek

    Tuesday, May 14, 2013 6:07 PM
  • Thats what I am working on now.. just never actually seen this before (been using MDT for a long time...)  I will keep you posted.  I just didnt know if there way any way to enable debugging or something to an external drive or something... I hate not being able to see any logs when things break ;)

    Tuesday, May 14, 2013 6:09 PM
  • Can you elaborate on your setup. We currently use x131e  (3367AB1) with both 32 and 64 Windows 7 with only one issue, the wireless card driver likes to be installed as an application as part of the Task Sequence. Most Lenovo's seem to have one or two drivers that prefer it this way.
    Tuesday, May 14, 2013 6:10 PM
  • Also, are you using WAIK or ADK?

    David Coulter | | @DCtheGeek

    Tuesday, May 14, 2013 6:12 PM
  • we are using the 3371-7mu (amd) .  I will keep you posted as to what I find out :) just working on re-building the boot, and also creating an ISO for testing...

    I am thinking its a driver issue - as I can get into a prompt as soon as it boots into MDT, but then freezes...
    • Edited by Dan Baker Tuesday, May 14, 2013 6:16 PM
    Tuesday, May 14, 2013 6:15 PM
  • download just the nic driver and add it to a new selection profile and rebuild your boot wim.
    Tuesday, May 14, 2013 6:18 PM
  • waik
    Tuesday, May 14, 2013 6:19 PM
  • Yeah its a driver issue... Must have some conflicting driver somewhere... I guess I will keep this boot wim for these machines, and then test adding our other nic drivers for our other devices to see if one of them breaks it :)

    This gets me going.  I think I would much rather see a BSOD then just a frozen screen though ;)

    Tuesday, May 14, 2013 7:16 PM
  • Yeah, when it freezes, it freezes.  Only way I've ever found to debug it is "go clean" and build back in till it breaks so I can find what's totally thrashing it.  Good luck finding that driver! : )

    David Coulter | | @DCtheGeek

    Tuesday, May 14, 2013 7:19 PM
  • I am not going to stress about it... worst case scenario I will just keep this boot image :)  Not that I dont want to know whats messing it up... but there is is not an easy way that does not take hours to figure it out :) Even then I may find out that the driver causing an issue is one needed for another system to boot.... so the cycle...

    On another note how are you guys handling boot driver issues like this.  Do you still use a single boot wim for your entire environment?

    Tuesday, May 14, 2013 7:30 PM
  • Yes, we have a single boot image (well, one x86, one x64) that supports 25-30 models (currently).  We put as FEW drivers as possible into the Boot Image to keep it clean.  If something works without adding a driver, we don't add a driver.

    Also note that using ADK (WinPE 4.0) seems to have better support built in for many drivers (including touch and USB->NIC adapters for things like Surface Pro).  I honestly don't think we've added ANY drivers other than what it comes with since we moved to it from WAIK (WinPE 3.0).

    David Coulter | | @DCtheGeek

    Tuesday, May 14, 2013 7:35 PM
  • makes sense - like I said I usually dont even touch it :)  But this time it didnt work.  I guess I will go down to basics and just bring in a SMALL number of drivers, maybe have a selection profile just for boot images, I guess that would make sense.

    Thanks for the input, I will look into the ADK, as I will be moving in that direction sooner than later :)

    Tuesday, May 14, 2013 7:52 PM
  • Yes, a Selection Profile for Boot Images (and only network and storage) is very recommended.  You don't want to inject everything into WinPE.  That will make it larger than necessary and can also complicate things (as you've just seen). : )

    David Coulter | | @DCtheGeek

    Tuesday, May 14, 2013 8:28 PM
  • You can get a full set of drivers for the little Lenovo from Lenovos site from their downloads page.

    I can get as far as LiteTouchPEx64.wim when booting from the network and even get as far as Run the Deployment Wizard to Install a new Operating system or Exit to command prompt but when I choose Run the deployment wizard to install a new operating system it throws back a wizard error. :- 

    A connection to the deployment share(MDT\DeploymentShare$) could not be made. The following networking device did not have a driver installed. PCI\VEN_10EC&DEV_8168&SUBSYS_21FD17AA&REV_07

    Did I inject the wrong network driver into the bootwim using dism? Is there a way to do this with Deployment Workbench?

    Tried to rebuild boot wim and it still gave me the error.

    Friday, September 20, 2013 9:14 PM