locked
Copied files from external drive all marked read only RRS feed

  • Question

  • I have retired a Windows 2003 Server Std that was used only as a file and print server.  I upgraded the hardware and loaded Windows 2003 Server Std on a new box. I copied all of the Users folders from the old server to an external drive.  I then in turn copied them from the external drive to the new server.  They are all marked as Read Only and I cannot figure out how the change the attribute. 

    I can only guess that I did something wrong when copying the files to the external drive.  I must have copied the former NTFS permissions when copying and now I can't read them.  How can I copy the files to an external source and then copy them to my new server? 

    Many thanks!

    Matt

     

     

    Thursday, November 11, 2010 7:58 PM

Answers

  • Hi

    I figured it out.  The attrib utility did not work.  What I ended up doing was (1) did a MS Backup of the data to BKF (2) Created a data folder at the destination with the appropriate NTFS permissions at the folder (3) restore the data to that folder (4) assigned permissions to each users folder. 

    Matt


    Matt
    Monday, November 15, 2010 6:43 PM

All replies

  • Hi Matt,

     

    Thanks for posting here.

     

    According what you described , I think this is normal . For security reason , all new created folder will be set read-only attribute by default in windows and this is also by design .

    You could remove it by using Attrib utility ,for more information please take look the article below:

     

    You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, in Windows Vista or in Windows 7

    http://support.microsoft.com/kb/326549/en-us

     

    Meanwhile, seems you are using windows server 2003 , based on my knowledge you may try  backup all files and folders first by using windows backup tools(Ntbackup) and restore it after hardware replacement finished ,so that all attribute settings should be reserved.

     

    Thanks.

     

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Meinolf Weber Friday, November 12, 2010 8:35 AM
    Friday, November 12, 2010 2:37 AM
  • Hi

    Thanks for the info.  The Attrib utility did not work.  I believe I followed the instructions properly - they were pretty simple.  Ntbackup.exe and the Backup utility are the same thing - right?  Can I use the Backup utility?  You stated below that the settings should be reserved.  What does that mean? I am copying files FROM a retired server AND a retired domain.  I would rather back up the files with no attributes and set them after I copy them to their destination.  Is that possible?  Thanks

    "

    Meanwhile, seems you are using windows server 2003 , based on my knowledge you may try  backup all files and folders first by using windows backup tools(Ntbackup) and restore it after hardware replacement finished ,so that all attribute settings should be reserved."


    Matt
    Friday, November 12, 2010 4:33 PM
  • Hi Matt,

     

    Thanks for update.

     

    Based on my test, I could remove read-only  attribute form a folder by using “Attrib” with “-r” parameter, for example I could remove read-only  attribute form folder c:\test by perform “attrib –r c:\test”.

    Could you try it and check if it worked in your environment ?

     

    Meanwhile, like I mentioned in my last reply , the Read-only attribute for a folder will be checked by default , however this setting will not affect your system ,because Windows , Windows components and accessories, and other programs will ignore it.  For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. For more explanation, please take look “Cause” paragraph in the KB article 326549.

     

    I have to correct my last reply, the reservation part I mentioned is for file and folder permission , not for attribute. If you do not want reserve the original attributes or permission, after coping to new environment, the attributes and permission will be inherited from parent folder or specially assigned.

     

    Thanks.

     

    Tiger Li

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, November 15, 2010 2:45 AM
  • Hi

    I figured it out.  The attrib utility did not work.  What I ended up doing was (1) did a MS Backup of the data to BKF (2) Created a data folder at the destination with the appropriate NTFS permissions at the folder (3) restore the data to that folder (4) assigned permissions to each users folder. 

    Matt


    Matt
    Monday, November 15, 2010 6:43 PM
  • Hi Matt,

    Thanks for update.

    Glad you fingure out the way to achieve your goal.

    Tiger Li

    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, November 16, 2010 1:22 AM