none
Windows Time Server setting not following group policy

    Question

  • I hardly use group policy, except for two settings:

    • User Configuration\Administrative Templates\System\User Profiles\Exclude directories in roaming profile
    • Computer Configuration\Administrative Templates\System\Windows Time Service\Configure Windows NTP Client & Enable Windows NTP Client

    The first setting has worked perfectly for years, but the second one seems to have stopped working, in that the time on client PCs has become out by several minutes. The client PCs are running Windows 7 and Windows 8.1.

    Following is the result under [TimeProviders] when I run W32TM /query /configuration:

    On the server:

    NtpClient (Local)
    DllName: C:\Windows\system32\w32time.dll (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)
    AllowNonstandardModeCombinations: 1 (Local)
    ResolvePeerBackoffMinutes: 15 (Policy)
    ResolvePeerBackoffMaxTimes: 7 (Policy)
    CompatibilityFlags: 2147483648 (Local)
    EventLogFlags: 0 (Policy)
    LargeSampleSkew: 3 (Local)
    SpecialPollInterval: 3600 (Policy)
    Type: NTP (Policy)
    NtpServer: time.windows.com,0x9 (Policy)

    NtpServer (Local)
    DllName: C:\Windows\system32\w32time.dll (Local)
    Enabled: 1 (Local)
    InputProvider: 0 (Local)
    AllowNonstandardModeCombinations: 1 (Local)

    On the Windows 8.1 client PC:

    NtpClient (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)
    CrossSiteSyncFlags: 2 (Local)
    AllowNonstandardModeCombinations: 1 (Local)
    ResolvePeerBackoffMinutes: 15 (Local)
    ResolvePeerBackoffMaxTimes: 7 (Local)
    CompatibilityFlags: 2147483648 (Local)
    EventLogFlags: 1 (Local)
    LargeSampleSkew: 3 (Local)
    SpecialPollInterval: 3600 (Local)
    Type: NT5DS (Local)

    VMICTimeProvider (Local)
    DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)
    NtpServer (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 0 (Local)
    InputProvider: 0 (Local)

    Can anyone help me to fix this please so that the client PCs sync their time correctly with an NTP server?

    Sunday, March 15, 2015 5:44 PM

Answers

  • Hi,

    >>but the second one seems to have stopped working, in that the time on client PCs has become out by several minutes. The client PCs are running Windows 7 and Windows 8.1.

    Does this happen to all clients in our environment? For group policy, we can run command gpresult/h gpreport.html with administrative privileges to collect group policy result to have a check. Besides, we can check event logs in Event Viewer to see if some related events were logged.

    Here, we can try to resync time with domain by following the steps described in the article below.

    Configure a client computer for automatic domain time synchronization

    https://technet.microsoft.com/en-us/library/cc758905(v=ws.10).aspx

    In addition, regarding time configuration in Active Directory, the following article can be referred to for more information.

    “It’s Simple!” – Time Configuration in Active Directory

    http://blogs.technet.com/b/nepapfe/archive/2013/03/01/it-s-simple-time-configuration-in-active-directory.aspx

    Best regards,

    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 16, 2015 7:25 AM
    Moderator