none
Project 2010 after Service Pack 2 does not respect the Windows list separator in field's formula box RRS feed

  • General discussion

  • The list separator used in formulas in the custom fields is defined by Windows. In my case which my customers work in Portuguese language, the list separator is semicolon, which is used in function like IIf(;;).

    After Service Pack 2 for 2010 it changed the list separator to comma, so now I need to write as in US, like IIf(,,) ignoring the Windows setting.

    Fortunaley this pack did not affect the older formulas and they continue to work, but it is hard to explain to advanced users why Microsoft changed this, isn'it?


    Best regards, Ricardo Segawa - Segawas Projetos / Microsoft Partner

    Wednesday, October 2, 2013 2:59 AM

All replies

  • R.Segawa,

    I don't think it is related to the SP2 update. I use Windows 7 with Project 2010 with SP2. I have USA language settings which uses a comma as the default list separator. As a test I changed the Windows list separator to a semicolon. I then opened Project and customized an extra text field with a formula. I typed the formula using a comma is the list separator. I received no error message and the formula worked as expected. When I opened the custom fields window to check the formula I found that Project/Windows had automatically changed the list separator to a semicolon. My conclusion is that Project will "adjust" its list separator to agree with the Windows default setting and the SP2 update is not a factor.

    What is the actual problem? Are the formulas not working? When you look at the list separator for Windows and then look at a typical custom field in Project, are the list separators different?

    John

    Wednesday, October 2, 2013 3:33 PM