locked
Hypervisor launch failed RRS feed

  • Question

  • I got starnge errors today - Hypervvisor is not starting due to tchem - restart does not help, no updates were installed lately. It is almost clean installation - Hyper-V role only.

    Event ID:      36

    Hypervisor launch failed; the image \windows\system32\mcupdate_GenuineIntel.dll failed code integrity checks, and cannot be used.

    Event ID:      37

    Hypervisor launch failed; the image mcupdate_GenuineIntel.dll does not contain the image description datastructures, and cannot be used.

    The file "mcupdate_GenuineIntel.dll" is readable and unmodified.

    Any ideas?

    Best Regards

    Tomek

    Tuesday, May 5, 2015 11:02 AM

Answers

All replies

  • hi i have exactly same error, someone solved this?
    Tuesday, May 5, 2015 2:53 PM
  • So, maybe it is not coincidence? Maybe MS makes some updates to the server code?

    When it was happen? Could you provide some additional information?

    I have ASRock Rack C2750D4I motherboard with 32GB RAM - used just as Hyper-V server - no additional software. It was running without any problems till today's morning and just stopped working after unexpected reboot (blue screen / crash?).

    Tuesday, May 5, 2015 3:59 PM
  • hi i have msi board and nothing happens with hw no crash no nothing, weird behavior so i try to in place update with new build 10074 and it works again :)
    Tuesday, May 5, 2015 4:10 PM
  • I noticed this crash only by checking event log & by fact that all VM's were shutdown. I didn't noticed when server was restarted but I found "The previous shutdown was unexpected" event in the event log.

    After further investigation I found these files were changed and have new dates:

    ci.dll
    crypt32.dll
    winload.efi
    winload.exe
    winresume.efi
    winresume.exe
    wintrust.dll

    Contents of these files seems to be legitimate.

    Anyway, after reinstallation my server works too.

    • Proposed as answer by Alex Lv Monday, May 11, 2015 1:27 AM
    Tuesday, May 5, 2015 6:20 PM
  • Hi Tomek_M,

    Form the event it most possible caused by the system data corrupt or driver issue or may there have some system file corrupted if you meet the same issue later please try to check your system hard disk health status, update your hardware driver and try to run the sfc /scannow cmdlet command to perform a system file fix.

    More information:

    Code Integrity

    https://technet.microsoft.com/en-us/library/dd348642%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    Viewing Code Integrity Events

    https://msdn.microsoft.com/en-us/library/windows/hardware/ff553952(v=vs.85).aspx

    I’m glad to be of help to you!


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com


    • Edited by Alex Lv Thursday, May 7, 2015 3:09 AM
    • Proposed as answer by Alex Lv Friday, May 8, 2015 7:37 AM
    • Marked as answer by Alex Lv Monday, May 11, 2015 1:27 AM
    Thursday, May 7, 2015 3:08 AM