locked
Exchange 2010 sp1 hosting set-Outlookprovider RRS feed

  • Question

  • Anyone able to set-outlookprovider for organization?

    i try to run get-outlookprovider -organization abc -identity EXPR | set-outlookprovider -certprincipalname "msstd:mail.abc.com"

    but it should me an error the operation couldn't be performed because object 'abc\expr' couldn't be found on AD001.abc.com

     

    Please help

     

    Wednesday, April 20, 2011 6:54 AM

Answers

  • Hi,

     

    The parameter of Organization is available for multi-tenant deployments. It isn't available for on-premises deployments.

    The Organization parameter specifies the organization in which you'll perform this action. This parameter doesn't accept wildcard characters, and you must use the exact name of the organization.

     

    Try this command:

    [PS] C:\Windows\System32>Get-OutlookProvider –Identity EXPR | Set-OutlookProvider –CertPrincipaName msstd:mail.abc.com

     

    After this ,run this command to verify the result:

    [PS] C:\Windows\System32>Get-OutlookProvider –Identity EXPR |FL

     

    Resource:

    Get-OutlookProvider

    Set-OutlookProvider


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Jerome Xiong Monday, April 25, 2011 9:47 AM
    Thursday, April 21, 2011 9:03 AM

All replies

  • Hi,

     

    The parameter of Organization is available for multi-tenant deployments. It isn't available for on-premises deployments.

    The Organization parameter specifies the organization in which you'll perform this action. This parameter doesn't accept wildcard characters, and you must use the exact name of the organization.

     

    Try this command:

    [PS] C:\Windows\System32>Get-OutlookProvider –Identity EXPR | Set-OutlookProvider –CertPrincipaName msstd:mail.abc.com

     

    After this ,run this command to verify the result:

    [PS] C:\Windows\System32>Get-OutlookProvider –Identity EXPR |FL

     

    Resource:

    Get-OutlookProvider

    Set-OutlookProvider


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Jerome Xiong Monday, April 25, 2011 9:47 AM
    Thursday, April 21, 2011 9:03 AM
  • HI,

    We are using multi-tenant deployments.

    Try to set the command but it still having an issue to login using outlook 2007 and outlook 2010 in windows xp machine.

    Do we need to set in outlook provider in organization?

    Please help.

     

    Best Regards,

    Stanley

    Thursday, April 28, 2011 1:44 AM