locked
Mention format (FirstName LastName, no email) RRS feed

  • Question

  • Hello all, in my company whenever we work with the @mention feature in Outlook, it automatically adds the person in the format FirstName LastName (firstname.lastname@company.com)

    As we have a lot of names with multiple parts (firstname.van.der.lastname@company.com) you're never sure how many backspaces you're going to need, it just makes it really tedious to use the feature. I see in some videos and screenshots that people get FirstName Lastname format without the email address but I can't find any setting that controls the format. How can we set this up?

    Wednesday, September 5, 2018 8:06 PM

Answers

  • Indeed that fixes the issue for this test contact. How can I change the display as for contacts from my exchange global address book? Can I do that on my client, or can the admin change it? 

    Hi ExcelApostle,

    Have saved the contacts from the Global Address list to your own Contacts folder?

    Based on my test, generally the @mention text is corresponding with the Name field in the Offline GAL:

    But if I right click the contact and selelct "Add to Contacts", the contact properties window pop up with the Display as field automatically filled with both full name and the email address:

    After I saved the contact, I can reproduce your situation when using the @Mention feature. 

    Given the information above, please check the Offline GAL to see if the Name field is proper.

    If the Name filed in GAL is correct, please confirm if you have added the contacts to your own Contacts folder, if this is the case, as there is no built-in option available to bulk change the Display as field, you may need to manually modify the field.

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by ExcelApostle Wednesday, September 12, 2018 7:55 AM
    Monday, September 10, 2018 11:08 AM

All replies

  • Hi ExcelApostle,

    Is the email address also included in the popup autocomplete list suggestions?
    Does this issue occur whenever you use the @mention feature?

    According to the introduction in this official article, “by default, the contact's full name is included".  I tested on several machines and all get the expected behavior with full name showing up. Based on my test, it seems to me that the text behind "@" is corresponding to the Name field in the Address book. Please have a look at the Address book to see if the email address is included in the name field. 

    Any update, please feel free to share with us.

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, September 6, 2018 2:48 AM
  • Hi Yukia,

    I created a test contact test.contact@company.com. Below is the format of the mention.

    


    Monday, September 10, 2018 8:55 AM
  • Hi ExcelApostle.

    Would you please change the Display as field to "Test Contact" instead and check the result?

    You may need to delete the autocomplete cache first by starting typing "Test" in the To filed and clicking the cross("x") button behind "Test Contact (test.contact@company.com)".

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, September 10, 2018 9:06 AM
  • Indeed that fixes the issue for this test contact. How can I change the display as for contacts from my exchange global address book? Can I do that on my client, or can the admin change it? 
    Monday, September 10, 2018 10:18 AM
  • Indeed that fixes the issue for this test contact. How can I change the display as for contacts from my exchange global address book? Can I do that on my client, or can the admin change it? 

    Hi ExcelApostle,

    Have saved the contacts from the Global Address list to your own Contacts folder?

    Based on my test, generally the @mention text is corresponding with the Name field in the Offline GAL:

    But if I right click the contact and selelct "Add to Contacts", the contact properties window pop up with the Display as field automatically filled with both full name and the email address:

    After I saved the contact, I can reproduce your situation when using the @Mention feature. 

    Given the information above, please check the Offline GAL to see if the Name field is proper.

    If the Name filed in GAL is correct, please confirm if you have added the contacts to your own Contacts folder, if this is the case, as there is no built-in option available to bulk change the Display as field, you may need to manually modify the field.

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by ExcelApostle Wednesday, September 12, 2018 7:55 AM
    Monday, September 10, 2018 11:08 AM
  • Hi Yuki,

    I did some further testing.

    For external contacts, some have been added using their organizations format. For some customers I get Lastname, Firstname. For most (especially in my own country) FirstName LastName.

    For internal contacts, it seems that for all people who have joined the organization after me, I get FirstName Lastname. For everyone who was already there I get FirstName LastName <FirstName.LastName@MyCompany.com>

    Monday, September 10, 2018 1:42 PM
  • For internal contacts, it seems that for all people who have joined the organization after me, I get FirstName Lastname. For everyone who was already there I get FirstName LastName <FirstName.LastName@MyCompany.com>

    Hi ExcelApostle,

    Thanks for sharing your findings. As mentioned in my previous reply, have you checked the Name field in the Address book? Have you added these people to your own contacts folder?

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, September 11, 2018 7:07 AM
  • Hi Yuki,

    It seems there are a number of lists in the exchange that I can't remove. However, there were also contacts of employees in my personal contacts. I removed all of those and now the mentions work properly FirstName LastName for all internal contacts. Thanks for pointing out the way!

    Wednesday, September 12, 2018 7:56 AM
  • Hi Yuki,

    It seems there are a number of lists in the exchange that I can't remove. However, there were also contacts of employees in my personal contacts. I removed all of those and now the mentions work properly FirstName LastName for all internal contacts. Thanks for pointing out the way!

    My pleasure :D

    Great to see that it works now!! 

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, September 12, 2018 8:05 AM
  • Small headsup for anyone else: it seems outlook first searches contacts from your personal book, then the global list. So for all this time I used mostly the personal contacts. After deleting them it means the autocomplete is gone.

    So when write a mail to someone for the first time you have to press 'check names' to force outlook to search the global address book, after that the contact autocomplete will be restored.

    Wednesday, September 12, 2018 8:11 AM