none
Setting Up Sharepoint 365 Folder Access/Permissions

    Question

  • I'm new to Sharepoint am trying to tell which users can access which folders.  I select the folder/subfolder, go to Advanced, Share With, Advanced .... I then click Stop Inheriting Permissions, and then Grant Permission to the only user I want to have access this folder.  However, other 365 users that sign on can go to this folder and access the files in there.  I'm missing something at a conceptual level and would appreciate any guidance.  thx DMiller
    Tuesday, March 21, 2017 3:32 PM

Answers

All replies

  • After you stopped inheriting permissions did you remove the default permissions that were there earlier?

    There are several groups, like Site Owners and Site Visitors, which are there by default. 

    You can also check which users have permissions, by navigating to the folder's permissions page and clicking on "Check Permission". Type the name of the user and you will see how and what kind of permissions for this folder he has (e.g. through Custom Visitors group - Read permission).


    Tuesday, March 21, 2017 4:19 PM
  • Yes ... when I right-click on the folder and select "Share" I see users with Check Boxes but I can't do anything with them.  It also says "Open to Anyone with a Guest Link."  Since I really couldn't do anything there I went to Advanced; the only user I want shows up there, but when I "Check Permissions" I see other users have "Contribute" permission and when they sign in to this folder they're identified as "Guest Contributor."  Perhaps the key is removing the "Guest Link"; I'm not seeing where I can do that though.

    Tuesday, March 21, 2017 4:50 PM
  • Hi DMiller,

    Please select the folder and go to Advanced, Share With, Advanced .... then click Stop Inheriting Permissions.

    Click "Show users" in the yellow status bar.

    And then select all the default user permission and click "Remove User Permissions", then click "Grant Permissions" to grant permission to one user.

    More information:

    https://social.technet.microsoft.com/wiki/contents/articles/18203.sharepoint-2013-break-document-library-permissions-inheritance.aspx

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, March 22, 2017 6:25 AM
    Moderator
  • Each one of those steps worked perfectly, and I'm sure they will be useful for others as well.  After I followed these steps and used Check Permissions I got exactly the results I wanted.  However, after signing out and signing back in as a different user I saw that the Folder is open to Anyone with a Guest Link .... please let me know if I should start a new thread for this issue; I'm thinking that if I could get rid of the Guest Link option--which I can't figure out how to do--my  problems would be solved.  Thx again -- DMiller

    Wednesday, March 22, 2017 12:34 PM