none
HYPER-V 2016 VM-Switch event-id 236 - error

    Question

  • Hi,

    for some time, I have been plaguing this error message from several VMs (2016, 2012 R2 fullfixed) on a HYPER-V host. The HYPER-V host is a Windows 2016 Std.

    ************************************************************

    Protocol name: System
    Source:        Microsoft-Windows-Hyper-V-VmSwitch
    Date:         17.03.2017 12:03:22
    event-ID:   236
    Task categorie:none
    level:         error
    user:      NT VIRTUAL MACHINE\9F4201C3-EF10-4C5B-8CFF-8FDC519DD76B
    Computer:      HYP01-SRV.contoso.com
    description:
    Failed to allocate virtual function for NIC 9F4201C3-EF10-4C5B-8CFF-8FDC519DD76B--ED58F00B-022A-4589-B93A-FBCE5B6C86B3 (Friendly Name: Network card), state = {drive not ready}
    The drive is not ready. The lock could be open. Make sure that a volume is inserted into drive% hs and the drive lock is closed.

    ************************************************************

    The error appears when I start the VMs and then at certain time intervals.

    The VMs themselves run inconspicuously, but after a few days all VMs freeze.

    So I recreate the VMs with (only the vhdx files were obtained. Not fixed.

    What is the reason for?

    Thanx for our helps!


    Danke und liebe Grüße Oliver Richter

    Friday, March 17, 2017 2:22 PM

Answers

  • Problem is solved!

    I have reconfig the VMQ and RSS Settings on HYPER-V host and the error isdisappeared.

    Thanx


    Danke und liebe Grüße Oliver Richter

    Tuesday, March 21, 2017 1:08 PM
  • Hi,

    I do that like here:

    http://blogs.technet.com/b/networking/archive/2013/09/10/vmq-deep-dive-1-of-3.aspx

    https://charbelnemnom.com/2015/04/the-available-processor-sets-of-the-underlying-physical-nics-belonging-to-the-lbfo-team-nic-are-not-configured-correctly-hyperv-vmq-rss-lbfo/

    In my config the Supermicro Server have 4 x 10GBE NIC, two LAN NICs I have teamed, 2 x Intel XEON E5-2650, 128 GB DDR4 RAM

    CPU 0 core should reserved for system use, Setup NUMA to Round Robin
    and since one CPU core can handle up to 3,5 Gbps NIC Transfer, so I reserve four CPU cores for each 10 GB NIC.

    here are my NIC configs:

    • LAN1:
      • Set-NetAdapterVMQ -Name LAN1 -BaseProcessorgroup 0 –BaseProcessorNumber 1 -Enabled $True -MaxProcessorNumber 4 -MaxProcessors 4
    • LAN2:
      • Set-NetAdapterVMQ -Name LAN2 -BaseProcessorgroup 0 –BaseProcessorNumber 5 -Enabled $True -MaxProcessorNumber 8 -MaxProcessors 4
    • LAN3:
      • Set-NetAdapterVMQ -Name LAN3 -BaseProcessorgroup 0 –BaseProcessorNumber 9 -Enabled $True -MaxProcessorNumber 12 -MaxProcessors 4
    • LAN4:
      • Set-NetAdapterVMQ -Name LAN4 -BaseProcessorgroup 0 –BaseProcessorNumber 13 -Enabled $True -MaxProcessorNumber 16 -MaxProcessors 4
    • LAN-TEAM:
      • Set-NetAdapterVMQ -Name LAN-TEAM -BaseProcessorgroup 0 –BaseProcessorNumber 17 -Enabled $True -MaxProcessorNumber 24 -MaxProcessors 8

    and I also do this:

    optimize RSS Profiles:

    http://emulex.force.com/knowledgebase/articles/How_To/RSS-and-VMQ-Tuning-on-Windows-Server

    -         NUMA: Assigns RSS processors in a round robin basis across every NUMA node to enable applications that are running on NUMA servers to scale well.

    • Set-NetAdapterRss –name LAN1,LAN2 … LAN-TEAM –Profile NUMA

    • Set-NetAdapterRss –name LAN1,LAN2 … LAN-TEAM –MaxProcessorGroup 0
    • Set-NetAdapterRss –name LAN1,LAN2 … LAN-TEAM –MaxProcessorNumber 46
    • Set-NetAdapterRss –name LAN1,LAN2 … LAN-TEAM –BaseProcessorGroup 0
    • Set-NetAdapterRss –name LAN1 –BaseProcessorNumber 1
    • Set-NetAdapterRss –name LAN2 –BaseProcessorNumber 3
    • Set-NetAdapterRss –name LAN3 –BaseProcessorNumber 5
    • Set-NetAdapterRss –name LAN4 –BaseProcessorNumber 7
    • Set-NetAdapterRss –name LAN-TEAM –BaseProcessorNumber 9

    I can not guarantee that my configuration is optimal. At least the errors are gone and everything runs inconspicuously.

    I hope this helps you ;-)


    Danke und liebe Grüße Oliver Richter

    Friday, April 07, 2017 6:46 AM

All replies

  • What is the storage configuration of the host?

    What is the NIC configuration of the host?  What virtual switches have you defined on the hosts?


    tim

    Friday, March 17, 2017 11:22 PM
  • Problem is solved!

    I have reconfig the VMQ and RSS Settings on HYPER-V host and the error isdisappeared.

    Thanx


    Danke und liebe Grüße Oliver Richter

    Tuesday, March 21, 2017 1:08 PM
  • Hi Oliver,
    what exactly have you reconfigured?

    Frank

    Tuesday, March 28, 2017 1:42 PM
  • Yeah, I'm interested too
    Tuesday, April 04, 2017 5:42 PM
  • Hi,

    I do that like here:

    http://blogs.technet.com/b/networking/archive/2013/09/10/vmq-deep-dive-1-of-3.aspx

    https://charbelnemnom.com/2015/04/the-available-processor-sets-of-the-underlying-physical-nics-belonging-to-the-lbfo-team-nic-are-not-configured-correctly-hyperv-vmq-rss-lbfo/

    In my config the Supermicro Server have 4 x 10GBE NIC, two LAN NICs I have teamed, 2 x Intel XEON E5-2650, 128 GB DDR4 RAM

    CPU 0 core should reserved for system use, Setup NUMA to Round Robin
    and since one CPU core can handle up to 3,5 Gbps NIC Transfer, so I reserve four CPU cores for each 10 GB NIC.

    here are my NIC configs:

    • LAN1:
      • Set-NetAdapterVMQ -Name LAN1 -BaseProcessorgroup 0 –BaseProcessorNumber 1 -Enabled $True -MaxProcessorNumber 4 -MaxProcessors 4
    • LAN2:
      • Set-NetAdapterVMQ -Name LAN2 -BaseProcessorgroup 0 –BaseProcessorNumber 5 -Enabled $True -MaxProcessorNumber 8 -MaxProcessors 4
    • LAN3:
      • Set-NetAdapterVMQ -Name LAN3 -BaseProcessorgroup 0 –BaseProcessorNumber 9 -Enabled $True -MaxProcessorNumber 12 -MaxProcessors 4
    • LAN4:
      • Set-NetAdapterVMQ -Name LAN4 -BaseProcessorgroup 0 –BaseProcessorNumber 13 -Enabled $True -MaxProcessorNumber 16 -MaxProcessors 4
    • LAN-TEAM:
      • Set-NetAdapterVMQ -Name LAN-TEAM -BaseProcessorgroup 0 –BaseProcessorNumber 17 -Enabled $True -MaxProcessorNumber 24 -MaxProcessors 8

    and I also do this:

    optimize RSS Profiles:

    http://emulex.force.com/knowledgebase/articles/How_To/RSS-and-VMQ-Tuning-on-Windows-Server

    -         NUMA: Assigns RSS processors in a round robin basis across every NUMA node to enable applications that are running on NUMA servers to scale well.

    • Set-NetAdapterRss –name LAN1,LAN2 … LAN-TEAM –Profile NUMA

    • Set-NetAdapterRss –name LAN1,LAN2 … LAN-TEAM –MaxProcessorGroup 0
    • Set-NetAdapterRss –name LAN1,LAN2 … LAN-TEAM –MaxProcessorNumber 46
    • Set-NetAdapterRss –name LAN1,LAN2 … LAN-TEAM –BaseProcessorGroup 0
    • Set-NetAdapterRss –name LAN1 –BaseProcessorNumber 1
    • Set-NetAdapterRss –name LAN2 –BaseProcessorNumber 3
    • Set-NetAdapterRss –name LAN3 –BaseProcessorNumber 5
    • Set-NetAdapterRss –name LAN4 –BaseProcessorNumber 7
    • Set-NetAdapterRss –name LAN-TEAM –BaseProcessorNumber 9

    I can not guarantee that my configuration is optimal. At least the errors are gone and everything runs inconspicuously.

    I hope this helps you ;-)


    Danke und liebe Grüße Oliver Richter

    Friday, April 07, 2017 6:46 AM