locked
SCVMM 2012 SP1 and App Controller 2012: Retrieved data is incomplete RRS feed

  • Question

  • We're using SCVMM 2012 SP1 (version 3.2.8071.0) with App Controller 2012. The underlying structure is a couple of Hyper-V 2012 Clusters. One of our customers use the App Controller to manage their virtuals and once in a while they need to connect with the console.

    A few of those virtuals are being annoying and won't allow connection with the console. When we select the virtual in App Controller we get the message "Retrieved data is incomplete" on top of the screen, with the details:

    Category: Warning
    Message: Retrieved data is incomplete.
    Details: Category: Critical
    Message: 11418–ObjectsInaccessible
    Description: You do not have permission to access one or more of the objects required by this operation.
    Web error status: UnknownError
    Web response description: Forbidden - 11418-ObjectsInaccessible
    Web response status code: Forbidden

    Trying to open the console shows the same message: "You do not have permission to access one or more objects required by this operation". Connecting with a user that has administrative rights in SCVMM doesn't show the problem and can connect without any trouble.

    The only real difference with other VM's is that these are configured with an extra network adapter (which has also been added to the allowed networks that can be used by the self-service user, both in the User Role and the Cloud configuration) and a couple of fibre channel adapters.

    We created a test VM and added all the components that are added to one of the troublesome VM's mentioned in the first post, same issue with the console. We remove the fibre channel adapters: above errors don't show at all and the console can be contacted.

    Is there any way of adding rights to support the console on virtuals with fibre channel adapters connected?

    Wednesday, September 16, 2015 8:41 AM

All replies

  • Any help or suggestion of where to look would be appreciated
    Friday, October 2, 2015 9:16 AM
  • Hi

    Based on the error, the current user does not have permission to view the properties of the fiber channel adapters.

    Is App controller also SP1 and does the version of the VMM console on the App Controller server match the version of VMM?

    App Controller needs to match the service pack version of VMM and the VMM console on the App Controller server must be the same update rollup as the VMM server.

    Do you have issues connecting to the console of the VM from within the VMM console when logged in as the user who is not an administrator?

    Within the VMM console are you able to specify permissions for the fiber channel adapters?

    If the above doesn't help, you may need a support case to investigate this further.

    Regards

    Richard


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, October 6, 2015 9:49 PM
  • Thank you for your response.

    I might have made a mistake in mentioning the versions: we're using SCVMM 2012 R2 (there's no SP1 involved in here) and App Controller 2012 R2. We checked the VMM and AC servers and both contain the same version of VMM. Rollup 7 has been installed on both servers as well.

    When connecting to the console with the user role our customer is using we don't have this issue. Since this customer isn't part of our domain, they can't use the console itself and have to use the app controller.

    I can't find any setting which sets the permissions for fibre channel adapters. Also, I haven't found any command (Powershell, for example) either. Is there any way of specifying permissions for these adapters?

    Monday, October 12, 2015 12:18 PM
  • I am also receing this error only on VMs with Virtual HBAs. This previously worked and has only come to our attention today. We are using VMM 2012 R2 UR5 and App Controller 2012 R2. We have also seen this on our VMM 2012 R2 UR7 setup.

    Has anyone been able to resolve this please?

    Monday, October 26, 2015 4:30 PM
  • Thanks for sharing that it's not just me. Let's hope MS is still trying to fix this.
    Tuesday, November 24, 2015 8:28 AM