locked
MySQL install error on new computer (Windows 7 Professional) RRS feed

  • Question

  • When installing MySQL I receive the following error:

    Could not access network location \Hewlett-Packard\\.

    I have checked the registry entries as per document: http://support.microsoft.com/kb/886549
    and they are fine.  This is a brand new machine right out of the box.  I have installed other software without incident.

    Any help would be greatly appreciated.

    Thursday, December 8, 2011 11:46 PM

Answers

  • What does MySQL technical support have to say about your issue?

    http://forums.mysql.com/

    Have you tried running the MySQL installer As Administrator?

    • Marked as answer by Cloud_TS Friday, December 16, 2011 1:04 AM
    Saturday, December 10, 2011 4:42 PM

All replies

  • What does MySQL technical support have to say about your issue?

    http://forums.mysql.com/

    Have you tried running the MySQL installer As Administrator?

    • Marked as answer by Cloud_TS Friday, December 16, 2011 1:04 AM
    Saturday, December 10, 2011 4:42 PM
  • This is probably cruft left behind by the HP OEM imaging process. To fix it, go into regedit and look in the registry under these two keys:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\

    If you see an "InstallLocation" value containing \Hewlett-Packard\\ just delete it. Then the software should be OK.

    This value is somehow getting pulled into the MSI installer property "INSTALLDIR", though I'm not sure why. I'm also not sure why this impact some installers but not others, nor is it clear this is a bug in the installer (it sounds like an HP issue to me).

    Steve (exMVP)

     

     


    Steve Friedl | Orange County, California | UNIX Wizard | Microsoft Security MVP | steve@unixwiz.net
    • Proposed as answer by Dudeman 3000 Monday, April 30, 2012 2:03 AM
    Tuesday, January 17, 2012 4:46 PM
  • Rough.  I just got this same error.

    I played with MySQL 6 years ago and I remember it was a pain in the ass to install.  I've been using MS SQL Server for the last 6 years.  I download the latest MySQL installer and I get this error where I have to change registry keys right away?  Weak.

    I guess this might be an HP problem but how come this problem isn't handled by the installer code?  Is the installer code open source too?  I might rather edit that to ignore this directory rather than mess with my Registry Keys which have been fine with the 50 programs I've managed to install.

    Maybe I just shouldn't bother...


    Monday, April 30, 2012 1:16 AM
  • Thanks Steve, this worked for me.
    Monday, April 30, 2012 2:00 AM
  • I had the same error and found this while searching for answers.  Thank you for pointing us to the correct place in the registry to fix this problem!
    Tuesday, June 5, 2012 6:15 PM
  • THANKS... WORKS FLAWLESS...!
    Friday, July 27, 2012 9:12 PM
  • Thanks a lot Steve, it works. And yes, it should be an HP issue.

    • Edited by Omartsc Wednesday, August 8, 2012 10:20 PM
    Wednesday, August 8, 2012 10:19 PM
  • Thanks Steve, you safe my life.
    Tuesday, June 11, 2013 12:57 PM
  • thanks Steven, work like a charm!
    Wednesday, July 24, 2013 8:16 AM
  • Just to add, what I did was simply use the MYSQL Installer to install a slightly earlier version (5.1 rather than 5.6) (64bit) my needs are simple and so the version is not critical. It installed no problem.  :D

    • Proposed as answer by Andy Rusch Tuesday, December 16, 2014 5:22 PM
    Tuesday, August 6, 2013 12:06 AM
  • well "Piltdown Man" I have been having repeated problems with using the MYSQL Installer to install version 5.6.14 of MYSQL. Everything installs fine EXCEPT for the top component in the list of components, the server itself! I have tried editing the Registry for those 2 things as I use a HP computer but I still fail to install the [MYSQL] server. Can u please help me with this problem?

    Steve R. Burrus

    Monday, September 2, 2013 5:02 PM
  • thank you very much for your post it was very helpful 
    Tuesday, October 14, 2014 1:47 PM
  • Unfortunately I am getting the same Hewlett-Packard error, but I have no registry keys that match! I searched those locations (manually) as well as doing an entire search of the registry for "hewlett-packard" and there is nothing!

    I installed v. 5.1 per the other user and that worked fine.

    Tuesday, December 16, 2014 5:21 PM
  • Thank you for this!! I did not have any hewlett-packard registry entries on my entire system, but it would not install 5.6. I installed 5.1 and it worked fine! THANK YOU!
    Tuesday, December 16, 2014 5:22 PM