locked
Can't open Central Administration RRS feed

  • Question

  • Hi,

    I have installed windows server 2003 OS in my PC. Later I installed Visual studio 2008 and Microsoft Office 2007. Then I installed IIS and Active Directory and Configured the DNS server. After that I installed MOSS 2007 software.

    But while opening the Central administration 3.0 I am receiving error: Application error. It happened previously. SO I formatted the D:Drive and installed everything. But I am facing the same application error while opening Central administration 3.0.

     

    Please help me out in this issue. Regards,

    Vamsi krishna S.K


    • Moved by Alexander.Burton Thursday, April 21, 2011 9:13 AM WSS 3.0 question (From:Project Server - Setup, Upgrade, Administration and Operation)
    • Edited by Mike Walsh FIN Thursday, April 21, 2011 3:36 PM NEVER push people into answering your questions. Text removed. (Just Wait). Also "Hi" has no place in forum Titles which are for problem descriptions - removed.
    Thursday, April 21, 2011 2:57 AM

Answers

  • Hi,

     

    According to your description, I suggest that you should run the command below when you got an error:

    1.        #CD D:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

    2.        #aspnet_regiis -ga "NT AUTHORITY\NETWORK SERVICE"

    3.        #aspnet_regiis.exe –i

    4.        Restart IIS and restart server.

    Please have a try.

     
    Best Regards
    David Hu

     

    • Marked as answer by Emir Liu Thursday, May 5, 2011 8:45 AM
    Monday, May 2, 2011 1:27 AM

All replies

  • If you can provide more details on what you mean by 'application error' and exactly what error you get (on screen / Windwos/ ShrePoint logs) when try to open the Central Aministration site - that would help.

    Did the Configuration Wizard complete all the steps?

    Can you browse the site from the IIS?

    Let us know what you find.

    Thanks!


    BlueSky2010
    Thursday, April 21, 2011 1:17 PM
  • Hi,

    While opening the Central administration in share point I am getting the following error:

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="RemoteOnly"/>
      </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
      </system.web>
    </configuration>

    And the Domain controller name is SKVK.Tech.Com. This the name I gave  while configuring active Directory and DNS. I don't know how to browse central administration from IIS. I think I followed all the steps in configuration Wizard.

    Do you need any more information. Please help me out. I have to work on share point. I look forward to hear from you.

    Thanks,

    Vamsi Krishna S.K

    Tuesday, April 26, 2011 3:05 PM
  • Follow the instructions in that error message.

    Next time (having done that) you will get a more useful error message that you can inform us about


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Tuesday, April 26, 2011 3:13 PM
  • Hi,

    I have edited web config file in root directory. Set the CustomErrors Mode="Off" and got the following error message. Please fix the issue.

     

    Server Error in '/' Application.

    The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'D:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'D:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'D:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.]
      System.Web.HttpRuntime.SetUpCodegenDirectory(CompilationSection compilationSection) +3570267
      System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags) +218
    
    [HttpException (0x80004005): The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'D:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.]
      System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +3465427
      System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +69
      System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +279
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

     

    Thanks,

    Vamsi S.K

    Wednesday, April 27, 2011 4:52 PM
  • Hi,

     

    According to your description, I suggest that you should run the command below when you got an error:

    1.        #CD D:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

    2.        #aspnet_regiis -ga "NT AUTHORITY\NETWORK SERVICE"

    3.        #aspnet_regiis.exe –i

    4.        Restart IIS and restart server.

    Please have a try.

     
    Best Regards
    David Hu

     

    • Marked as answer by Emir Liu Thursday, May 5, 2011 8:45 AM
    Monday, May 2, 2011 1:27 AM
  • Thanks David. Its work for me. Now I can able open central administration.

     Regards,

    Vamsi Krishna S.K

    Tuesday, May 10, 2011 5:15 AM