none
All SPcommon icons displayed instead of Sync icon at Project Site's library RRS feed

  • Question

  • Hello. Recently we migrated our Project Server from 2013 to 2016 version following the official guide (using DB attach method).

    Migration itself went flawlessly witouht errors.

    But now I see a strange behaviour:

    1) Open any Project site

    2) Go to Documents library (default library template)

    3) Click Sync button

    A dialog with one and only "Sync now" button appears. But now instead of Sync button it displays a whole bunch of spcommon icons:

    Usually it looks like:

    This bug doesn't happen on libraries in root of PWA (i.e. where Server Settings, Project, Issues, Reports). It also cannot be reproduced on fresh new PWA with newly created project sites. 

    Only on ALL migrated project sites.

    When I looking at DOM of this Sync now dialog, it looks like: 

    <div class="ms-core-menu-item" style="padding: 5px 0px; margin-bottom: 20px;">
    	<a class="ms-core-menu-link" id="ms-syncPopupButton" onclick="return false;" href="#">
    		<span class="ms-syncButtonIconParent">
    			<img class="ms-syncButtonIcon" src="/PWA/_catalogs/theme/Themed/9EE39AD6/spcommon-B35BB0A9.themedpng?ctag=0">
    			</span>
    			<span style="margin- vertical-align: top;">Sync now</span>
    		</a>
    	</div>

    but on newly created project site it looks like:

    <div class="ms-core-menu-item" style="padding: 5px 0px; margin-bottom: 20px;">
    	<a class="ms-core-menu-link" id="ms-syncPopupButton" onclick="return false;" href="#">
    		<span class="ms-syncButtonIconParent">
    			<img class="ms-syncButtonIcon" src="/_layouts/15/images/spcommon.png?rev=40">
    			</span>
    			<span style="margin- vertical-align: top;">Sync now</span>
    		</a>
    	</div>
    	

    That is, <img> source is looks different, specifing to correct sprite (rev=40).

    I definitely don't know how to fix this and change that icon source and why this bug happens. Any ideas?

    upd:

    On new PWA with new project site this icon source looks like:

    <img class="ms-syncButtonIcon" src="/PWA2/_catalogs/theme/Themed/6C49BCF0/spcommon-B35BB0A9.themedpng?ctag=0">

    i.e. without specifiyng certain revision. And it is displayed correctly.

    Also, the synchronization itself worked nice, the trouble only in displaying this particular dialog box with "Sync now" button.

    • Edited by Lehus Wednesday, June 13, 2018 3:25 PM
    Wednesday, June 13, 2018 3:17 PM