locked
Hdd recognize RRS feed

  • Question

  • Hello! I have a toshiba A300 notebook with a fujitsu hdd. Windows 7 seems to does't recognize him like an intern hdd, and shows him in traybar under safty remove hardware. If I chose in bios compatibility mode,instead of ahci mode everything is fine. Please, does anyone know how can I fix this ?

    Thursday, June 25, 2009 9:24 AM

Answers

  • omega,

    This shouldn't be a problem at all - it's possible that your notebook simply supports SATA hot-swapping (which would be disabled when running the device in legacy ATA mode), and this it its way of telling you so. Given that your OS is running from that drive, it's likely that Windows wouldn't allow you to remove the drive if you ever tried to do so, but having the option is perfectly harmless, and you'll enjoy considerable performance advantages when running in AHCI mode, so I'd recommend that you continue doing so.
    -Alex
    • Marked as answer by Nick FV Thursday, June 25, 2009 5:26 PM
    Thursday, June 25, 2009 3:14 PM

All replies

  • omega,

    This shouldn't be a problem at all - it's possible that your notebook simply supports SATA hot-swapping (which would be disabled when running the device in legacy ATA mode), and this it its way of telling you so. Given that your OS is running from that drive, it's likely that Windows wouldn't allow you to remove the drive if you ever tried to do so, but having the option is perfectly harmless, and you'll enjoy considerable performance advantages when running in AHCI mode, so I'd recommend that you continue doing so.
    -Alex
    • Marked as answer by Nick FV Thursday, June 25, 2009 5:26 PM
    Thursday, June 25, 2009 3:14 PM
  • Thanks Alex. I was thinking that only extern hdd's should be in that list of safty remove hardware, it's absolute useless to have a safty remove hardware for the intern hdd. But if this is how sata hot-swapping works I think I am fine now.
    Have a nice day!
    Thursday, June 25, 2009 6:04 PM