none
12+monitor setups in windows 10 are much slower at certain tasks compared to windows 7 RRS feed

  • Question

  • Hi, I was told to post here instead of another forum. I work IT where our current setups have win7 machines with 12-16 1200p monitors rocking i7-4930k, 32gb ram, and 3-4 pny nvidia quadro 600/620 gpus.

    When we have upgraded a few of our systems to 10 both fresh and just standard 7>10 upgrade we have noticed that system operation is sluggish on all systems when dealing with multimon setup using both windows built in program display settings and also the nvidia software. It takes forever to rotate a single display, or to rearrange, or even to just launch display settings.

    certain programs also do not behave well anymore one is our propietary software and another is google chrome. what happens is when hovering or switch to such apps the computer seems to stall for a few seconds. other programs do not have this problem, and it does not happen when we remote into said computers.

    Another problem is logging into the local computer after it has been remoted, it takes an incredible amount of time to load the desktop compared to win7.

    If anyone has any suggestions besides upgrading the cpu,motherboard, and gpu I would be most thankful as those are last resorts.

    Monday, January 27, 2020 5:23 PM

All replies

  • Hi, 

    Try to update system to the latest system build through Windows update or deploy the latest update package in your environment through WSUS or SCCM. Also please uninstall the existing graphic driver and BIOS driver, then download the latest corresponding driver from device manufacturer website. 

    If the issue persists, we would recommend to monitor performance through Windows Performance Analyzer to check which thread consume a long time.

    Bests,


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 29, 2020 10:07 PM
    Moderator
  • Hi,

    Haven't received your message a few days, was your issue resolved? 
    I am proposing previous helpful replies as "Answered". Please feel free to try it and let me know the result. If the reply is helpful, please remember to mark it as answer which can help other community members who have same questions and find the helpful reply quickly.

    Bests,

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 10, 2020 4:05 PM
    Moderator