none
MDT 8443 Capture Image - Location and WIM name RRS feed

  • Question

  • I just upgraded MDT to 8443 and ADK for 1703. I have a Capture created for a test 1703 VM.
    When I get to the point of where to capture the image,
    "Specify whether to capture an image"
    the "Capture an Image of this Reference Computer" looks different than the prior version. I can type the path to where I want it saved, but I have no entry where I can type the pc name.
    As of now, my image is capturing as MININT-L6DS1K3.wim

    There is no File Name:___ entry and the Location:___ is blank.

    Thanks for any assistance.

    Thursday, August 31, 2017 7:01 PM

All replies

  • Add following lines to your CustomSettings.ini

    ComputerBackupLocation=%DeployRoot%\Captures
    BackupFile=%OSDComputername%_#replace(date,"/",".") & ".wim"#

    The first line specifies the backup location, the second one specifies WIM file name - in my example I am using the computer name generated by MDT and append today's date, so that the resulting image is timestamped.

    Mind you, from the way the string looks, you are using MDT's default computer name which is being generated at run time. You can work around that either by changing computer name in the GUI or setting computer name in CustomSettings.ini using OSDComputerName= property. 


    Blog - http://www.vacuumbreather.com / http://www.wcsaga.com

    • Proposed as answer by Anton Romanyuk Friday, September 1, 2017 3:08 PM
    Thursday, August 31, 2017 8:23 PM
  • In the past, in the prior version of MDT, I've always been prompted to enter the WIM file name and the location was always pre-populated. Is it correct that now to pre-populate the location, it is added as above in the INI, while the pc name prompt no longer exists in the Capture Wizard?

    I don't do any query for pc names and such, just type one in during the Capture Wizard. Additionally, during the Deployment, I assume there is a spot to add a pc name while joining to the domain. Thanks

    Thursday, August 31, 2017 8:28 PM
  • MDT should prompt you, unless you entered SkipComputerName=YES etc in your CustomSettings.ini

    Blog - http://www.vacuumbreather.com / http://www.wcsaga.com

    Thursday, August 31, 2017 8:44 PM
  • On my current server (MDT 2013 U2), my BUILD Custom Settings are:
    SkipComputerName=YES

    but I get prompted to add a name for the WIM I'm about to capture.

    On my test server with MDT 8443, the Build is the same:
    SkipComputerName=YES

    Neither has mention of Computer Backup.

    Do  I need to change my settings to specify computer name as you mentioned as well as location, during the Capture, with 8443? It was different in 2013U2.

    Thursday, August 31, 2017 8:52 PM
  • Not that I am aware of. Then again, I usually just automate everything as outlined above. 

    From the looks of it, OSDComputerName value is used to name your image, so you could probably re-enable that wizard pane to work around the issue. Without seeing your CustomSettings.ini I am afraid I can't be of more help.


    Blog - http://www.vacuumbreather.com / http://www.wcsaga.com

    Thursday, August 31, 2017 9:54 PM
  • This is all I've ever had in my Build Custom settings, and I've always been prompted to type in a pc name as well as the location being auto-filled...

    OSInstall=Y
    SkipAppsOnUpgrade=NO
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerName=YES
    SkipDomainMembership=YES
    SkipUserData=YES
    UserDataLocation=YES
    SkipLocaleSelection=YES
    SkipTaskSequence=NO
    SkipTimeZone=YES
    SkipApplications=NO
    SkipBitLocker=YES
    SkipSummary=YES
    SkipBDDWelcome=YES
    SkipCapture=NO
    DoCapture=YES
    SkipFinalSummary=NO

    Friday, September 1, 2017 1:12 PM
  • Looks reasonable as far as I can tell. Which brings me back to my original suggestion: use CustomSettings.ini to set Capture location / image name. :)


    Blog - http://www.vacuumbreather.com / http://www.wcsaga.com

    Friday, September 1, 2017 1:18 PM
  • So just add these two lines to my current Settings I posted above....

    ComputerBackupLocation=%DeployRoot%\Captures
    BackupFile=%OSDComputername%_#replace(date,"/",".") & ".wim"#

    Friday, September 1, 2017 1:30 PM
  • Yes. I am not 100% sure referencing %OSDComputerName% at this stage of the gather process will set the correct computer name, unless you are also setting OSDComputerName property in your CustomSettings.ini.

    You could work around this by using a task sequence specific TS: see my blog post on how to implement a TS speicic CustomSettings.ini


    Blog - http://www.vacuumbreather.com / http://www.wcsaga.com

    Friday, September 1, 2017 2:06 PM