locked
Word documents take 30 secs to load if they have a non-standard template imbedded in them (Windows7 client only) RRS feed

  • Question

  •  

    Until recently I had a Vista client with Office 2007. No problems
    Then I got a new laptop with Windows 7 Enterprise (32-bit) and Office 2007.

    After a couple of weeks every Word document I opened took about 30 secs to open
    if the document had a template imbedded in it that was not the Normal.dot or that
    pointed to a folder the creator of the document had defined (eg c:\temp\myfolder\).

    When I deleted the entry for the imbedded template the file opened immediately, no matter if the file was on my local machine, in an e-mail or on a network share. But I get so many word documents I cannot wait half a minute every time I open a document.

    So I added the registry entry UseTimeoutForAttachedTemplateLoad to HKCU\Software\Microsoft\Office12\.0\Word\Options and tried different values (from 3000 to 300 msec) but this had no effect whatsoever.
    Our internal support suggested that I re-install Office which I did, but the problem remained.
    So they suggested I should install Office 2010 instead which I did, but the problem remained.

    Logging on as a different user on my machine showed that the problem did not occur for this user and was user related.
    So I deleted my Windows user profile and restarted the machine. The problem was gone.
    Well for a week or so.
    And now it is back.

    Any ideas anyone?

    Thursday, April 5, 2012 8:40 AM

Answers

  • Hi,

    Please clear the “Automatically update document styles” check box in “Global templates and Add-ins” dialog box.

    Microsoft Office button -> Word Option -> Add-in -> drop down Manage box, select Templates -> click Go button.



    If the template under “Global templates and Add-ins” box, please remove the template from Startup folder:

    C:\Users\{username}\AppData\Roaming\Microsoft\Word\STARTUP

    Best Regards.


    William Zhou

    TechNet Community Support


    Saturday, April 7, 2012 8:46 AM