locked
Can not access AD-RMS right protected document through external URL. RRS feed

  • Question

  • Hi All,

    I have migrated RMS server from IRM (Windows server 2003 R2) to AD-RMS (Windows server 2008 R2). Server details are as below. 

    ADRMS Server 01 - ADRMSSVR01 - 192.168.1.1

    ADRMS Server 02 - ADRMSSVR02 - 192.168.1.2

    Internal URL - mobinternal.contoso.int

    External URL - mobexternal.contoso.com

    Once i completed the migration about 6 months back external user could able to open right protected their documents without any issue. Now users could right protect their documents and open those internally but they can not open it when they connect to internet. It will give below error.


    Appreciate  your quick response.

    Dilshan

     


    Tuesday, July 31, 2012 10:00 AM

Answers

All replies

  • Do you see any records in exterbal AD RMS logs? Is the server reachable?

    Martin

    Thursday, August 2, 2012 7:53 AM
  • Hi Martin,

    Where should i check logs?


    Saturday, August 4, 2012 9:57 AM
  • Check the IIS logs located in C:\inetpub\logs\LogFiles see if you can find any recent events for clients accessing licensing pipeline from outside (https://rms-uri.external.com/_wmcs/licensing/license.asmx). Also check application log for errors.

    Regards

    Martin

    Monday, August 6, 2012 7:17 AM
  • Hi Martin,

    As i mentioned earlier in this loop external traffic come from mobexternal.contoso.com will hit to NLB IP, Since i wanted to isolate the issue i have change the traffic routine from NLB IP to ADRMSSVR01 Server IP (192.168.1.1). Then i could one issue. When i try to access below URL, 

    http://mobexternal.contoso.com/_wmcs/licensing/license.asmx.

    It will prompt me to enter the credentials. Then i tried to provide credential with external domain name (Ex : contoso.lk\dilshan and password) but it didn't work, But the odd thing is when i try to enter credentials with internal domain name (Ex : contoso.int\dilshan) i will get the license page. Here im so confused why it gives the license page when i enter the internal domain name information, And internal domain name information are not even published to out side. Now i'm pretty sure when someone try to access he document using the internal URL.

    Need a workaround ASAP,

    Dilshan

    Tuesday, August 7, 2012 5:42 PM
  • Not sure if I understand you correctly. You have to Active Directory domains? Or you are just running two servers in one Active Directory (external / internal facing RMS).

    Could you please describe your setup thorougly?

    Martin

    Wednesday, August 8, 2012 3:13 PM
  • Earlier all traffic came to the RMS NLB IP, but in order to isolate the issue i did point the incoming traffic to ADRMSSVR01 (RMS server 01). Now when i try to access the this URL http://mobexternal.contoso.com/_wmcs/licensing/license.asmx it prompt security dialog box to enter the user name and password. Below herewith are the external and internal domain name of the organization.

    External Domain name - contoso.lk

    Internal Domain name - contoso.int

    Once the security dialog box appears i tried to enter the user credentials with external domain name (contoso.lk\dilshan) but it didn't work.... but again when i try to enter the credentials with internal domain name i could access default page which appear once i browse the above mentioned URL (http://mobexternal.contoso.com/_wmcs/licensing/license.asmx). But still i could not access the document

     

    Wednesday, August 8, 2012 3:52 PM