locked
SharePoint 2010 MP for SCOM 2016 RRS feed

  • Question

  • Hi,

    I am trying to monitor a SharePoint 2010 environment in SCOM 2016, but I receive the following error when running the configuration task:

    The Event Policy for the process started at 14:10:45 has detected errors in the output. The 'StdErr' policy expression:

    .+

    matched the following output:

    Exception calling "Load" with "1" argument(s): "Could not load file or assembly 'Microsoft.EnterpriseManagement.Core, Version=7.0.5000.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified."

    Failed to load Microsoft.EnterpriseManagement.Core.dll

    Command executed: "C:\Windows\system32\cmd.exe" /c powershell.exe -Version "2.0" -NoLogo -NoProfile -Noninteractive "$ep = get-executionpolicy; if ($ep -gt 'RemoteSigned') {set-executionpolicy remotesigned} & '"C:\Program Files\Microsoft System Center 2016\Operations Manager\Server\Health Service State\Monitoring Host Temporary Files 19\18387\AdminTask.ps1"' 'SharePointMP.Config'"

    Working Directory: C:\Program Files\System Center Management Packs

    One or more workflows were affected by this.

    Workflow name: Microsoft.SharePoint.2010.SCOM2012.ConfigSharePoint

    Instance name: Microsoft SharePoint 2010 Farm Group

    Instance ID: {B7E9A5AF-62D1-CF79-0AE8-044AE7CECBD7}

    Management group:

    Error Code: -2130771918 (Unknown error (0x80ff0032)).

    It appears to me it is looking for an old .dll file. Anyone experienced this and found a fix?

    The issue is also stated in the SharePoint forum: https://social.technet.microsoft.com/Forums/sharepoint/en-US/02d43fdd-bd8a-42d5-ab0e-6d7869cc942a/sharepoint-2010-mp-in-scom-2016?forum=operationsmanagermgmtpacks

    Wednesday, February 1, 2017 2:45 PM

Answers

  • I have talked to Microsoft, and the SharePoint 2010 mp is not supported with SCOM 2016, and there are currently no plans for an upgrade.
    • Marked as answer by Michael Skov Wednesday, February 8, 2017 9:19 AM
    Wednesday, February 8, 2017 9:19 AM

All replies

  • Did you copy and modify the sharepointmp.config file to the right location on your RMSe? 

    Regards, Blake Email: mengotto<at>hotmail.com Blog: http://discussitnow.wordpress.com/ If my response was helpful, please mark it as so, if it answered your question, then please also mark it accordingly. Thank you.

    Wednesday, February 1, 2017 9:01 PM
  • Hello,

    Have you followed the article below to configure SharePoint 2010 MP?

    https://blogs.technet.microsoft.com/momteam/2012/04/16/kb-configuring-the-sharepoint-2010-management-pack-for-system-center-operations-manager/

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, February 2, 2017 2:43 AM
  • Yes, I have configured the mp a million times. The error is related to a .dll file

    Exception calling "Load" with "1" argument(s): "Could not load file or assembly 'Microsoft.EnterpriseManagement.Core, Version=7.0.5000.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified."

    Failed to load Microsoft.EnterpriseManagement.Core.dll

    Thursday, February 2, 2017 12:03 PM
  • Yes, I have configured the mp a million times. The error is related to a .dll file

    Exception calling "Load" with "1" argument(s): "Could not load file or assembly 'Microsoft.EnterpriseManagement.Core, Version=7.0.5000.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified."

    Failed to load Microsoft.EnterpriseManagement.Core.dll

    Thursday, February 2, 2017 12:03 PM
  • I have talked to Microsoft, and the SharePoint 2010 mp is not supported with SCOM 2016, and there are currently no plans for an upgrade.
    • Marked as answer by Michael Skov Wednesday, February 8, 2017 9:19 AM
    Wednesday, February 8, 2017 9:19 AM
  • Hi Michael,

    i'm having the exact same issue.

    So this is official from Microsoft that SharePoint 2010 is not supported in SCOM 2016? I need this to clarify to customers who are using SP 2010.

    Thanks,

    Janez

    Monday, September 25, 2017 9:52 PM
  • Yes. I have created my own management pack instead.
    Tuesday, September 26, 2017 12:32 PM
  • So if I understand right you manage to monitor SP 2010 in SCOM 2016 with official MP and your own modifications.

    Or you build your own custom management pack for monitoring SP2010?

    Wednesday, September 27, 2017 6:18 AM
  • I have build my own custom management pack for SP2010.
    Wednesday, September 27, 2017 6:52 AM