none
No longer able to deploy msi through GPO RRS feed

  • Question

  • Hello, 

    We have been unable to install apps made available through GPO since update KB4541335.  There is a known issue on that update that seems to be our issue, however it lists it fixed in KB4549951, and that is not the case for us. I have verified this issue exists on multiple devices running version 2004, updated just yesterday.

    The .msi failure seems to have issue accessing our file share where we are redirecting user data. This was not an issue on versions pre-KB4541335. I'll post the .msi log file below.  Event viewer just shows a 1603 error.  Any help would be greatly appreciated. 

    === Verbose logging started: 7/9/2020  15:16:42  Build type: SHIP UNICODE 5.00.10011.00  Calling process: C:\WINDOWS\system32\svchost.exe ===
    MSI (c) (28:B0) [15:16:42:809]: User policy value 'DisableRollback' is 0
    MSI (c) (28:B0) [15:16:42:809]: Machine policy value 'DisableRollback' is 0
    MSI (c) (28:B0) [15:16:42:809]: Note: 1: 2318 2:  
    MSI (c) (28:B0) [15:16:42:810]: Note: 1: 2318 2:  
    MSI (c) (28:B0) [15:16:42:810]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
    MSI (c) (28:B0) [15:16:42:810]: Executing op: Header(Signature=1397708873,Version=500,Timestamp=1351852109,LangId=1033,Platform=0,ScriptType=3,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=0)
    MSI (c) (28:B0) [15:16:42:811]: Executing op: ProductInfo(ProductKey={6FBA0CCD-A1E4-4765-AF7A-68961DE667CA},ProductName=zzzzzzzz,PackageName=zzz.msi,Language=1033,Version=18219011,Assignment=0,ObsoleteArg=0,ProductIcon=zzz.ico,,PackageCode={35086B9F-CC85-4D65-88ED-2852017CA3FE},,,InstanceType=0,LUASetting=0,RemoteURTInstalls=0,ProductDeploymentFlags=2)
    MSI (c) (28:B0) [15:16:42:811]: SHELL32::SHGetFolderPath returned: \\zzz.com\zzz\UserData\name\AppData\Roaming
    MSI (c) (28:B0) [15:16:42:817]: SHELL32::SHGetFolderPath returned: \\zzz.com\zzz\UserData\name\AppData\Roaming
    MSI (c) (28:B0) [15:16:42:840]: Folder is not accessible: \\zzz.com\zzz\UserData\name\AppData\Roaming\Microsoft\Installer\
    MSI (c) (28:B0) [15:16:42:840]: Error: Failed to Create AppData Cache Folder
    MSI (c) (28:B0) [15:16:42:840]: Note: 1: 2318 2:  
    MSI (c) (28:B0) [15:16:42:841]: Executing op: Header(Signature=1397708873,Version=500,Timestamp=1357478422,LangId=1033,Platform=0,ScriptType=2,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=1)
    MSI (c) (28:B0) [15:16:42:841]: Executing op: End(Checksum=0,ProgressTotalHDWord=0,ProgressTotalLDWord=0)
    MSI (c) (28:B0) [15:16:42:841]: Error in rollback skipped.	Return: 5
    MSI (c) (28:B0) [15:16:42:843]: Note: 1: 2318 2:  
    MSI (c) (28:B0) [15:16:42:843]: DoAdvertiseScript is returning: 1603
    === Verbose logging stopped: 7/9/2020  15:16:42 ===
    


    Friday, July 10, 2020 8:05 PM

All replies

  • Hello,

    Thank you for posting in our TechNet forum.

    According to your description, we are not able to deploy msi via GPO.

    The .msi is stored under \\zzz.com\zzz\UserData\name\AppData\Roaming\Microsoft\Installer\. But it seems that this folder is not accessible. We could have a check whether it could access the above folder.

    How we redirected the user data, folder redirection or roaming user profile? If we created another folder share for .msi, such as \\fileserver\shared folder, could it be able to install apps?

    For any question, please feel free to contact us.


    Best regards,
    Hannah Xiong

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, July 13, 2020 5:24 AM
  • Hello,

    I am checking how the issue is going, if you still have any questions, please feel free to contact us.

    Thank you so much for your time and support.

    Best regards,
    Hannah Xiong

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 16, 2020 5:07 AM
  • Hello,

    Does this question have any update or has this issue been solved? Also, for the question, is there any other assistance we could provide?

    Thank you so much for your time and support.

    Best regards,
    Hannah Xiong

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 20, 2020 1:55 AM