none
Set file association using GPP

    Question

  • Hi

    I am trying to change the default application used to open a particular file type. I tried it on the person's Windows 7 computer (in an AD domain).

    I have tried changing the default file association using Control Panel. However, the text and the tick box "Always use the selected program to open this kind of file" is greyed out. Also, when I browse and navigate to the .exe I want to be the default program, after selecting it the new .exe is not added to the list.

    I thought I'd use Group Policy Preferences instead. However, when I right click Folder Options under Control Panel Settings and choose 'Open With' it won't accept the path I specify because the application is not installed on the server on which I am editing Group Policy. ????

    Is there a way for me to set this, please?

    Ideally, I would like to be able to edit the clients directly without the need to use GPP where an application is used just on one machine. But, it would also be useful to be able to set some global options without the need to edit every single person's file associations.

    If anyone knows how to make changing file associations from the client editable that would be great. I don't understand why it is greyed out - is this something I may have set in Group Policy and have forgotten about?

    Thanks.

    Tuesday, April 7, 2015 1:46 PM

Answers

  • Hi,

    Regarding the "Always use the selected program to open this kind of file" feature grayed out in the control panel issue, you can log in with the admin account and then follow the below steps: 

    >>Open regedit

    >>Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

    >>Find your extension

    >>Delete the UserChoice key

    WARNING: Using Registry Editor incorrectly can cause serious problems. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. And also suggest op to backup  the registry before edit.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Mark-Blood Tuesday, April 14, 2015 11:10 AM
    Monday, April 13, 2015 6:48 AM
    Moderator

All replies

  • > right click Folder Options under Control Panel Settings and choose 'Open
    > With' it won't accept the path I specify because the application is not
    > installed on the server on which I am editing Group Policy. ????
     
    Simply type the path, do not use the browse button :)
     

    Greetings/Grüße, Martin

    Mal ein gutes Buch über GPOs lesen?
    Good or bad GPOs? - my blog…
    And if IT bothers me - coke bottle design refreshment (-:
    Tuesday, April 7, 2015 2:40 PM
  • Thanks for replying. That works.

    Next - can anyone help me resolve the problem with the Control Panel feature being greyed-out on the client machines, please?

    Thanks.

    Wednesday, April 8, 2015 8:44 AM
  • Hi,

    Regarding the "Always use the selected program to open this kind of file" feature grayed out in the control panel issue, you can log in with the admin account and then follow the below steps: 

    >>Open regedit

    >>Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

    >>Find your extension

    >>Delete the UserChoice key

    WARNING: Using Registry Editor incorrectly can cause serious problems. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. And also suggest op to backup  the registry before edit.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Mark-Blood Tuesday, April 14, 2015 11:10 AM
    Monday, April 13, 2015 6:48 AM
    Moderator
  • That's great, Elaine

    Removing the registry entry did not change the greyed-out status next to 'Always use the selected program...', but the program that it should have been associated with was now available to choose from in the top pane.

    We were trying to change .indd files. They were opening with CS2 but we had installed CS6 and after installation they were still opening in CS2.

    Many thanks!

    Tuesday, April 14, 2015 11:14 AM