locked
SPOOLSV.EXE HAS HIGH CPU UTILIZATION RRS feed

  • Question

  • I'm running XP/SP3 on a home network... The HP L7550 printer is on the network... The spoolsv.exe spooler gradually consumes more and more system resources until the system grinds to a halt with the spooler showing 80-90% CPU utilization.  There are no print jobs waiting to be printed (Windows>system32>Spool>Printers is empty)... There is no AV sw running... I have uninstalled the HP drivers and reinstalled the newest ones... This problem isn't unique to me as I have seen several internet queries for the same problem from different users but no workable solution is given... It seems that this is a MS problem, but I can't find a solution here either... Anyone know how to make this problem go away?

     

    TIA

    Monday, December 20, 2010 12:34 PM

All replies

  • Performance issues with the print sppoler are mostly closely related to the drivers used on the system.

    I would recommend to uninstall the drivers and clean up the spooler (http://support.microsoft.com/kb/324757). If the printers is networked/shared, please make sure to uninstall the drivers from the server too. Unisntall all HP software, use the tool provided by HP to clean out (on the driver downloadpage)

    After that you could try to install the drivers as provided by hp. Choose the basic ones (even better: the enterprise version...)  for now, just to exclude issues.

     


    MCP/MCSA/MCTS/MCITP
    Monday, December 20, 2010 2:09 PM