none
OLAP Database Build Settings Error The operation was not completed RRS feed

  • Question

  • I have Project Server 2016 with SQL Server 2016 on one server

    When I try Create NEW Olap Build Settings or change the Default one in OLAP Database Management and click Save Return "The operation was not completed because the input was not valid, or the server failed"

    I check My Analysis Services Server name and it was Correct

    the database name dos not exit

    the user i use is sysadmin in sql and Analysis service also is SharePoint farmadmin

    I Install SP2 for SQL 2016 and last update for SharePoint but still get error

    anyone can help??




    Tuesday, September 25, 2018 8:53 AM

All replies

  • Did you install SQL Server 2014 Analysis Services?

    Refer to software requirements 

    https://docs.microsoft.com/en-us/project/software-requirements-for-project-server-2016

    Project Server always seems a version behind with SQL analysis server. 

    Cube Building Service requirements

    SQL Server 2014 Analysis Services must also be installed on your SQL Server 2014 database server for your SharePoint Server 2016 Enterprise deployment if you plan to use the Cube Building Service in Project Server 2016.


    Michael Wharton, Project MVP, MBA, PMP and a Great Guy <br/> Website http://www.WhartonComputer.com <br/> Blog http://MyProjectExpert.com contains my field notes and SQL queries


    Tuesday, September 25, 2018 10:46 PM
    Moderator
  • Hi Michael

    tnx for Reply

    i installed SQL 2016 and analysis services 2016

    do i need downgrade analysis services to 2014??


    Saturday, October 6, 2018 9:08 AM
  • No, just need to use the older add-ins.   They will work fine for the newer versions.  Its just project server services needs the older add-ins.

    Michael Wharton, Project MVP, MBA, PMP and a Great Guy <br/> Website http://www.WhartonComputer.com <br/> Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Saturday, October 13, 2018 2:13 AM
    Moderator
  • i install SQL_AS_AMO 2014 but noting change. still get the same error

    Tuesday, October 23, 2018 12:18 PM
  • 1) Make sure Firewall is down or ports open for analysis server

    2) try using fully qualified name hostname.domainname.local

    3) make sure that service has access to analysis server


    Michael Wharton, Project MVP, MBA, PMP and a Great Guy <br/> Website http://www.WhartonComputer.com <br/> Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Saturday, October 27, 2018 12:16 PM
    Moderator