none
Event 21034 - LS Address Book Server - Normalization Search RRS feed

  • Question

  •     There is plenty of information out there regarding Normalization and modifying things so that this error isn't received.  The question I have is I would like to find the user(s) that don't follow the E.164 convention however if I look at the text file - Invalid_AD_Phone_Numbers -  I see:

    Unmatched number: User: 'ed3e7368-fcd6-4280-bfa5-aa5a5acbe430'  AD Attribute: 'telephoneNumber'  Number: 'xxxxxxxxxx@txt.att.net'
    Unmatched number: User: 'dc65786c-125a-44ba-a369-462f3a13cb65'  AD Attribute: 'telephoneNumber'  Number: 'xxxxxxxxxx@txt.att.net'

    I've done a few searches for Telephone Number and putting in the "number" listed however it doesn't find anything.  Is there an easy way of finding out what object has that information assigned to it without having to search all of AD for a particular string?

    Thanks!

    Thursday, May 2, 2013 3:45 PM

Answers

  • Hi Lisa,

        Thanks for the response. 

    1. From appearances, it looked like it wasn't picking up all the changes made in AD made to ANY/ALL users that had normalization issues because I went through almost every user that was in the first normalization text file and corrected everything.

    2. In looking at the installation, it appears there was a problem with the "Web Services" component so I went ahead and removed the component and re-installed it.  Once I did that, no more normalization problems showed up *HOWEVER* the address book still isn't replicating over.  I'll put a post in the Lync 2013 forum to see if I can get assistance with the replication issue.

    Again, thank you! :)

    Friday, May 3, 2013 1:54 PM

All replies

  • The content in your text file Invalid_AD_Phone_Numbers is not correct.

    The right format is like this below:

    Unmatched number: User: ‘SIP:user@domain.com’ AD Attribute: ‘telephoneNumber’ Number:’display the phone number in AD telephoneNumber field’.

    You should check these two users’ attributes in AD user property.

    Try to delete the Invalid_AD_Phone_Numbers, then run the command

    Invoke-Csmanagementstorereplication to update this file.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, May 3, 2013 11:16 AM
    Moderator
  • Hi Lisa,

        Thanks for the response. 

    1. From appearances, it looked like it wasn't picking up all the changes made in AD made to ANY/ALL users that had normalization issues because I went through almost every user that was in the first normalization text file and corrected everything.

    2. In looking at the installation, it appears there was a problem with the "Web Services" component so I went ahead and removed the component and re-installed it.  Once I did that, no more normalization problems showed up *HOWEVER* the address book still isn't replicating over.  I'll put a post in the Lync 2013 forum to see if I can get assistance with the replication issue.

    Again, thank you! :)

    Friday, May 3, 2013 1:54 PM
  • Why every text message on this topic has been written twice?

    Friday, July 21, 2017 8:16 AM