locked
Microsoft Lync 2010 Remote Call Control (RCC) to Cisco Unified Presence Server 8 (CUPS) RRS feed

  • Question

  • Hi all,

     

    I was wondering if someone could help me with this integration, as I just can't get it to work. I was not able to find a lot of information about this.

     

    This is what I've done so far:

    Lync users can log-in and IM each other. 

    On Lync I've configured the following:

    via Lync Server Management Shell:

     

    $tcpRoute = NewCsStaticRoute -TCPRoute -Destination 10.4.1.5 -Port 5060 -MatchUri cups01.mydomain.com

    Set-CsStaticRoutingConfiguration -Route @{Add=$tcpRoute}

     

     

    in topology builder:

    Trusted application servers as a single computer pool:

    cups01.mydomain.com

     

    DNS server can resolve cups01.mydomain.com to 10.4.1.5

    In Lync Server 2010 Control Panel:

    I have imported an user, which has in Telephony: Remote call control

    Line URI: tel:1535;phone-context-dialstring

    sip:1535@cups01.mydomain.com

     

    ----------------------

     

    I am very new to this, can you please tell me if I've done something wrong? (which I obviously have!)

     

    Many thanks,

    • Moved by Ben-Shun Zhu Friday, March 4, 2011 6:46 AM incorrect queue (From:Lync Clients and Devices)
    Thursday, March 3, 2011 3:10 PM

All replies

  • Hi, your question falls into the paid support category which requires a more in-depth level of support.Please visit the below link to see the various paid support options that are available to better meet your needs.

    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, March 4, 2011 6:50 AM
  • paid support category? 

    I'm not asking you guys to do it for me. just to point me to the correct direction. documentation or something. 

    now, this really puts you off microsoft! we're deploying a POC on trial version in my company. and if we actually get it working microsoft might actually get a new large corporate customer on lync.

     

    but well, if the POC doesn't work I guess we stay with Cisco. happy days!

    Friday, March 4, 2011 10:46 AM
  • Hi,

    RCC integration is not an easy job and is difficult to troubleshoot through a forum, that's why Ben-Shun Zhu suggests you to contact support for extended help.

    Did you go through the RCC Deployment guide?


    Technical Specialist Microsoft OCS/Lync & UC Voice Specialisation - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    Thursday, March 10, 2011 7:08 PM
  • Hi all,

     

    Thank you Ruben very much, for pointing me into RCC Deployment guide at least! That's definitely very helpful.

    I tried to follow the guide, and I think I did configure everything correctly, but I can't get it work.

    Here's my integration details:

    I have this config:

    CUPS: cups01.mylab.com
    CUPS IP: 10.4.1.5
    lync: lync.otherdomain.net
    SIP Domain: mylab.com
    Lync FE Pool: lync.otherdomain.net
    this config:

    New-CsTrustedApplicationPool 10.4.1.5 -Registrar lync.otherdomain.net -Site 1 -TreatAsAuthenticated $true -ThrottleAsServer $true -RequiresReplication $false

    New-CsTrustedApplication -ApplicationID CUPS -TrustedApplicationPoolFQDN 10.4.1.5 -Port 5060 -EnableTcp

    Enable-CsTopology

    $TCPRoute = New-CsStaticRoute –TCPRoute –Destination 10.4.1.5 -Port 5060 –MatchUri cups01.lab.com

    Set-CsStaticRoutingConfiguration –Route @{Add=$TCPRoute}

    Set-CsRegistrar registrar:lync.otherdomain.net –SipServerTcpPort 5060

    and I have changed the parameter in a topology builder: limit service usage to selected IP Address to 10.4.1.5 and published topology again.

    As you see, CUPS and lync are on different domains. I wonder if that is a problem. as well I wanted to mention that, cups01.lab.com is resolvable through DNS of lync server to 10.4.1.5 so there should be no DNS problem.

    on Line URI: tel:1535 on Line SErver URI: sip:1535@cups01.lab.com

    I have tried all different combinations on Line Server URI: sip:10.4.1.5@lab.com sip:1535@lab.com

    LYNC is not even sending any packet at all to CUPS!!! nothing shows up on the wireshark towards 10.4.1.5

    I hope somebody can help me now, without asking for money! :) 

    Thanks guys, 

    Monday, March 28, 2011 11:49 AM
  • Hi, Sufle!

    After "Enable-CsTopology" did you do the following steps:

    1. Enter the following command to output the topology to an XML file called rcc.xml and save it to the C drive:

    Get-CsTopology -AsXml | Out-File C:\rcc.xml

    Note You can select any name and location to output the topology information. 

    2. Open the rcc.xml file. 

    3. In the Cluster Fqdn section, change the IPAddress parameter from “<0.0.0.0>” to the IP Address of the 

    CiscoUnifiedPresence server. 

    4. Save the rcc.xml file. 

    5. Enter the following command in the Lync Server Management Shell: 

    Publish-CsTopology -FileName C:\rcc.xml

    6. Enter the following command to restart the front-end service:

    Restart-Service RtcSrv

     

    Does it help?


    MCSE 2003, MCITP (Server Administrator, Enterprise Messaging Administrator)
    Friday, September 9, 2011 1:50 PM
  • We are having a similar issue trying to get RCC from Lync to Cisco phones going and have run into a roadblock.  We are looking for two results:  1.  A User should go “Busy” in Lync when they pick up their Cisco desk phone.  2.  A call to a Lync User from another Lync User should make the Cisco phone on the second User’s desk ring.

    Environment:

                    We have two Edge Server, three Front-Ends and monitor and a reporting Server.  The CUPs Server is version 8.5.

    We have followed all of the steps in the Cisco document here:  http://www.cisco.com/en/US/docs/voice_ip_comm/cucimoc/8_5/english/release/cucimocReleaseNote.html and I see the CUPS Server in the topology.  We have run the addrccmenu.bat file and have verified the telephone model number on the CUPS Servers web site at https://”CUPS-IP”:8443/cupuser/showHomeMini.do?mini=true.  The “Enable integration with your phone system” checkbox is greyed out so we cannot choose the Cisco phone as a phone.  The CUPS Server talks to Lync on port 6050, not 6065. And we have republished the topology with the IP address of the CUPS Server and the CUPS Server shows up as a trusted app.

     

    1. IP, Presence and Voice Conferencing using POTs work fine.  Even a 4-digit conference number defined in Cisco Call manager work fine.
    2. If we change a User to Enterprise Voice, Lync can make an outbound call from the Lync client.  RCC or RCC Only does nothing – no calls at all in either direction.
    3. We have rolled everything back and completed all of the tasks in the Cisco doc with the same result.
      ...just dome gereral direction would be appreciated.

    Thanks

    Friday, September 16, 2011 7:07 PM
  • WMAMAN,

     

    If you look at your mediation server logs when you place a call do you see the outbound connection to the cups server?  If so, what do the logs say one the CUPs side?


    BBB
    Friday, September 16, 2011 9:20 PM
  • Hi Sufle,

    How did you go resolving this issue?  I too have run through the cisco integration notes "IntegrationNote_CUP852_MicrosoftLyncServer2010_RCC.pdf" and am stuck (I think) on creating the right SRV records for my CUPs server, which isn't in the notes. Everything else is by the books..

    Appreciate any advice


    Wednesday, April 18, 2012 3:34 AM
  • Its been over a year, so bit rusty, but I do remeber running into an issue with domain names..

    RCC required password integration (AD, so lync and Cisco passwords are synced) for user to finish the sip call.

    if you have a complete test enviornment with cisco and MS you can test that out.

    I remeber pulling the trigger in my live enviornment because of not having a cisco test env.


    z



    • Edited by z_lives Wednesday, March 6, 2013 10:53 PM
    Wednesday, March 6, 2013 10:52 PM
  • probably need to do some sip trace to see if your cups is getting the right info. also I am assuming you have already enabled the user in CUPS for desktop phone contol. chances are you may need to contact cisco support.


    z

    Wednesday, March 6, 2013 11:08 PM
  • you mean DNS srv record?

    z

    Wednesday, March 6, 2013 11:09 PM