locked
Mobile / external Call drops RRS feed

  • Question

  • Dear All ,

    I have the following topology :

    1 FrontEnd  pool ( FE01 ,  FE 02 )

    1 Edge Pool (Edge01)

    Mobile and external users can login and use IM but can't make calls . Calls only work internally . when I run https://testconnectivity.microsoft.com test I am getting the following error :

    Couldn't sign in. Error: User failed to get response from MRAS server.
    SIP service request to MRAS server failed.
    Error Message: A 504 (Server time-out) response was received from the network and the operation failed. See the exception details for more information..
    Error Type: PublishSubscribeException.
    Fault Code: .
    Response Code: 504.
    Response Text: Server time-out.
    Diagnostic Header: ErrorCode=1014,Source=LyncFe02,Reason=Unable to resolve host name record,lookupfqdn=edgepool01

    Microsoft.Rtc.Signaling.DiagnosticHeader

    But I can resolve the edge pool from both FE server and telnet ( 443 , 4443 ,  5061 )

    Thanks in advance .

    Sunday, April 23, 2017 4:29 PM

Answers

  • Dear All ,

    Thanks for your help . Someone changed the webconf name in the topology to webcon . changing it to webconf in the topology solved the issue .

    • Marked as answer by Andrew Thabet Thursday, May 4, 2017 1:44 PM
    Thursday, May 4, 2017 1:44 PM

All replies

  • Hi,
    do you have removed the domain name from this log after "lookupfqdn=edgepool01" or this is exactly the log you get?
    In the second case, if your client try to connect to edgepool01 insted of edgepool01.yourdomain.com, you have a non-correctly configured deployment.
    Let me know, we can go futher after that answer.
    Regards
    Luca

    Luca Vitali - Skype for Business MVP | Enterprise Voice Specialist

    Sunday, April 23, 2017 9:59 PM
  • Hi Andrew,

    The MARS Server is the Media Relay Authentication Service. It looks like, the access to the AV Edge is not possible. It could be because of wrong DNS, Port or Certificate Settings. So please provide more information about the Certificate, the DNS Name for the AV Edge, the Port and the Firewall Rules.

    From the FE server, please double confirm that it resolve the internal IP of Edgepool01, instead of public IP address.


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 24, 2017 7:02 AM
  • Dear Luca ,

    Thanks for for reply . I have removed the the domain from the edge pool name and they were working till 5 days ago .

    Wednesday, April 26, 2017 8:23 AM
  • Hello Jim ,

    I will get the information need and reply to you . Thanks for your reply .

    Wednesday, April 26, 2017 8:24 AM
  • Hello Jim,

    I double checked the resolution and certificate :

    Certificate is still valid and it i public will the following SAN


    sip
    dialin
    officewebapp
    meet
    webconf
    extweb
    lyncdiscover

    43 and 5061 are opened between Edge server and FE and also published from Edge

    The FE can resolve Edge pool name and AV name internal IP .

    Wednesday, April 26, 2017 11:59 AM
  • Hi There.

    On your edge server - do you use 3 ipaddresses on the external nic and one on the internal nic?

    Do you use an external dns server on external nic and host file to resolve internal server names?

    Also do you use a reverse proxy by any chance to host your meet and dialin ip addresses?

    Which other ports do you have open between frontend servers and edge internal nic and also you need 443 and udp 3478 from your desktops to reach the edge internal nic as well. This is assuming you have a dmz with a firewall at either end.

    Wednesday, April 26, 2017 10:29 PM
  • Hello Daniel ,

    the edge external NIC has 3 IP and only one on the internal ip .For the DNS yes I have 8.8.8.8 on the external nic and  Frontend A record in the the hosts file . I am using TMG as reverse proxy . For the ports all the ports are opened between Edge and frontend do you suggest test specific port ?

    Sunday, April 30, 2017 6:48 AM
  • Dear Daniel,

    Thanks for your reply, yes the edge server external NIC has 3 IP and DNS 8.8.8.8 and 1 IP on the internal NIC. The hosts file has A record for Frontend.

    The reverse proxy is configured on TMG. All the ports are opened between all the servers can you suggest ports to test?

    Sunday, April 30, 2017 7:48 AM
  • The default gw of the edge is the external nic and all internal network subnet are added with route add -p?

    Can you check your edge configuration with this link?

    https://insidemstech.com/2014/05/10/step-by-step-lync-2013-edge-server/


    regards Holger Technical Specialist UC

    Sunday, April 30, 2017 9:54 AM
  • Hi Andrew

    Ok.

    you mentioned that you can resolve av.yoursipdomain from the frontend server? Please remove that entry from your internal dns as it should only be in external dns.

    Can you telnet on port 443 on the public ip for the av.yoursipdomain ?

    Did you do any ocslogger traces perhaps you can share?

    Tuesday, May 2, 2017 8:56 PM
  • Dear All ,

    Thanks for your help . Someone changed the webconf name in the topology to webcon . changing it to webconf in the topology solved the issue .

    • Marked as answer by Andrew Thabet Thursday, May 4, 2017 1:44 PM
    Thursday, May 4, 2017 1:44 PM
  • Hi Andrew,

    Thanks for your back and sharing us with your solution, it is helpful because it will help someone who has similar issue could find solution in this thread as soon as possible.


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Sunday, May 7, 2017 6:15 AM