locked
"Some" Drivers Not Installing OS Deployment Task Sequence RRS feed

  • Question

  • I have a task sequence that deploys Windows 7 and injects drivers using a selection profile and WMI query for model.  I also have the Inject Drivers task set to install all drivers, not just matching drivers.

    It works and installs the majority of drivers except two.  SM Bus (Intel Chipset) and Intel HD video drivers.  It installs Standard VGA generic video and then doesn't support dual monitors.

    The correct drivers are in the selection profile because, if I manually update the drivers from the workstation device manager and browse to the Out of Box drivers folder on the MDT server, the system is able to find the driver and install it.

    Is there anything that needs to be done to force it to install these drivers?

    Thursday, January 8, 2015 2:11 AM

All replies

  • Check the BDD.log file to see if your correct driver was copied locally (Search for xcopy).

    if the driver was not copied, then you have your culprit.

    If the driver *WAS* copied, then there is a different problem. if MDT is presented with more than one possible driver match for a device, then it will copy down *ALL* possible matches, and let the OS figure out which one Is best (newer). If you have more than one driver being copied down best to check the setupapi.*.log files to confirm which drivers were actually installed and why. Be aware that the setupapi log files are hard to read. sorry.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Friday, January 9, 2015 7:48 AM