locked
Problem with File Attachment Control while downloading attachment. in web enabled infopath 2010 form? RRS feed

  • Question

  • I can upload an attachment using file attachment control in web enabled infopath 2010 form. But when iam trying to download form after submiting form. Attachment is showing but when i try to download it throws error.

    Note : These infopath forms are migrated from 2007 to 2010.

     Error :

    System.ArgumentException: Value does not fall within the expected range.    at Microsoft.SharePoint.Library.SPRequestInternalClass.GetMetadataForUrl(String bstrUrl, Int32 METADATAFLAGS, Guid& pgListId, Int32& plItemId, Int32& plType, Object& pvarFileOrFolder)     at Microsoft.SharePoint.Library.SPRequest.GetMetadataForUrl(String bstrUrl, Int32 METADATAFLAGS, Guid& pgListId, Int32& plItemId, Int32& plType, Object& pvarFileOrFolder)     at Microsoft.SharePoint.SPWeb.GetList(String strUrl)     at Microsoft.Office.InfoPath.Server.Controls.FormServerAttachments.FileDownload(HttpContext context)     at Microsoft.Office.InfoPath.Server.Controls.FormServerAttachments.ProcessRequestInternal(HttpContext context)     at Microsoft.Office.InfoPath.Server.Controls.ProcessRequestPageBase.ProcessRequest(HttpContext context)     at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()     at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

     

    Please help... Thanks in advance


    Tuesday, July 19, 2011 3:55 PM

Answers

  • Issue Resolved By removing the Attachment control and replace with new Attachment control and republished the form.
    • Marked as answer by Tech-Fun Wednesday, July 20, 2011 1:55 PM
    Wednesday, July 20, 2011 1:55 PM

All replies

  • Issue Resolved By removing the Attachment control and replace with new Attachment control and republished the form.
    • Marked as answer by Tech-Fun Wednesday, July 20, 2011 1:55 PM
    Wednesday, July 20, 2011 1:55 PM
  • Hi,

    if...

    Issue Resolved By removing the Attachment control and replace with new Attachment control and republished the form.
    ...not work!

    Try this:

    - check your SharePoint version and verify if your ambient need this:

    http://support.microsoft.com/kb/2536598/en-us

     

    Friday, August 12, 2011 12:29 PM
  • This resolution does not work for us.  Removing and replacing has no effect. 

    The answer offers no explanation as to why removing and replacing the control should make any difference at all.

    In our case, the forms are developed on a development server and uploaded to test and production servers.  The forms work on development but fail on the test.

    Is this related to SharePoint and or Windows upates?  Both development and test servers are currently at 10.0.5128.500 (Oct 2010 CU).  The development OS is up-to-date with Windows update, but the test server OS has not been updated since 7/2011.

     

    Monday, October 10, 2011 4:04 PM
  • We experienced this problem and traced it to differences between the Windows Security patch levels between development and production systems.

    We feel this may well be related to security updates pushed during the timeframe following SharePoint 2010 SP1.  We suspect, but can't prove that it was KB2560890, which was pushed in mid-September.  http://www.microsoft.com/download/en/details.aspx?id=27375 

    In our case, the development server was set to automatically install security updates, while the production server was not. Neither server has SharePoint 2010 SP1 installed.  There are other issues associated with this combination (KB2560890 without SP1) and we suspect that this is one of them. 

    We suspect there are two resoutions:

    1. Implement SharePoint 2010 SP1.  (our sys admins aren't ready for that)
    2. Re-publish forms on a system with same patch level.  This is what we did and it resolves the issue for us. In our case, we had to install the InfoPath designer on a staging server with the same patch level as production.

    Thursday, December 1, 2011 4:29 PM