locked
Unable to resolve DNS - NAT, DHCP Working. RRS feed

  • Question

  • So, first attempt at getting a small business server off the ground - I've got internet and all is running well however DNS won't resolve, NSlookup shows Unknown server. Here are the ipconfig /all from my test bed.

     

    FROM CLIENT PC

     

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\Voxata>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Voxata-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : vox.local

    Ethernet adapter Local Area Connection 2:

       Connection-specific DNS Suffix  . : vox.local
       Description . . . . . . . . . . . : Intel(R) 82583V Gigabit Network Connectio
    n
       Physical Address. . . . . . . . . : F4-6D-04-2D-BB-7D
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::94f5:b56c:747c:1181%12(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.2.32(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Wednesday, August 17, 2011 4:52:21 AM
       Lease Expires . . . . . . . . . . : Thursday, August 25, 2011 4:52:21 AM
       Default Gateway . . . . . . . . . : 192.168.2.1
       DHCP Server . . . . . . . . . . . : 192.168.2.1
       DHCPv6 IAID . . . . . . . . . . . : 435449092
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-80-F2-FC-00-08-54-9C-AF-B4

       DNS Servers . . . . . . . . . . . : 192.168.2.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connectio
    n
       Physical Address. . . . . . . . . : F4-6D-04-2F-67-79
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{ADE35EDB-3191-4A41-A344-CC143EC1A284}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:cba:1010:e7ce:4f1c(Prefe
    rred)
       Link-local IPv6 Address . . . . . : fe80::cba:1010:e7ce:4f1c%13(Preferred)
       Default Gateway . . . . . . . . . : ::
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter isatap.vox.local:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : vox.local
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    FROM SERVER PC (2008 R2)

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\Administrator>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : WIN-0A2735ELSJ9
       Primary Dns Suffix  . . . . . . . : vox.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : Yes
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : vox.local

    Ethernet adapter Internet:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigab
    it Ethernet NIC (NDIS 6.20) #2
       Physical Address. . . . . . . . . : 00-1F-BC-01-C9-2B
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 127.0.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Network:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigab
    it Ethernet NIC (NDIS 6.20)
       Physical Address. . . . . . . . . : 00-1F-BC-01-C9-2A
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.2.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :
       DNS Servers . . . . . . . . . . . : 192.168.2.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{6FCCEB4A-3791-4646-95BE-731CD0A8B1EF}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 11:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{C0C778E1-1ABC-4E14-B72A-00C27B4AEAA3}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Wednesday, August 17, 2011 12:33 PM

Answers

  • Your Default Gateway (e.g. your router) and your DNS are both showing as 192.168.2.1. That is wrong. The DNS should be the address of the SBS server.

    It looks like it's your router that has handed out the IP address details (DHCP Server address) and that is also wrong.

    Disable DHCP on your router and enable it on the server. That should solve your problems. The DNS on your desktops/laptops should be the IP of the SBS machine.

     

     

    Jim


    • Proposed as answer by Bigteddy Wednesday, August 17, 2011 1:43 PM
    • Marked as answer by Rick Tan Monday, August 29, 2011 3:05 AM
    Wednesday, August 17, 2011 12:51 PM
  • Please have a look at these first

    http://blogs.technet.com/b/sbs/archive/2010/02/26/returning-small-business-server-2008-to-a-supported-network-topology.aspx

    http://blogs.technet.com/b/sbs/archive/2008/09/16/sbs-2008-supported-networking-topology.aspx

    • Marked as answer by Rick Tan Monday, August 29, 2011 3:05 AM
    Wednesday, August 17, 2011 1:53 PM
  • In addtion, it looks like two NICs are installed and connected. Later than SBS2003 you don't want this configuration.

    ------------

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigab
    it Ethernet NIC (NDIS 6.20) #2
       Physical Address. . . . . . . . . : 00-1F-BC-01-C9-2B
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 127.0.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Network:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigab
    it Ethernet NIC (NDIS 6.20)
       Physical Address. . . . . . . . . : 00-1F-BC-01-C9-2A
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.2.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :
       DNS Servers . . . . . . . . . . . : 192.168.2.1
       NetBIOS over Tcpip. . . . . . . . : Enabled


    /kj
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Rick Tan Monday, August 29, 2011 3:05 AM
    Wednesday, August 17, 2011 4:46 PM

All replies

  • Your Default Gateway (e.g. your router) and your DNS are both showing as 192.168.2.1. That is wrong. The DNS should be the address of the SBS server.

    It looks like it's your router that has handed out the IP address details (DHCP Server address) and that is also wrong.

    Disable DHCP on your router and enable it on the server. That should solve your problems. The DNS on your desktops/laptops should be the IP of the SBS machine.

     

     

    Jim


    • Proposed as answer by Bigteddy Wednesday, August 17, 2011 1:43 PM
    • Marked as answer by Rick Tan Monday, August 29, 2011 3:05 AM
    Wednesday, August 17, 2011 12:51 PM
  • Please have a look at these first

    http://blogs.technet.com/b/sbs/archive/2010/02/26/returning-small-business-server-2008-to-a-supported-network-topology.aspx

    http://blogs.technet.com/b/sbs/archive/2008/09/16/sbs-2008-supported-networking-topology.aspx

    • Marked as answer by Rick Tan Monday, August 29, 2011 3:05 AM
    Wednesday, August 17, 2011 1:53 PM
  • In addtion, it looks like two NICs are installed and connected. Later than SBS2003 you don't want this configuration.

    ------------

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigab
    it Ethernet NIC (NDIS 6.20) #2
       Physical Address. . . . . . . . . : 00-1F-BC-01-C9-2B
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 127.0.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Network:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigab
    it Ethernet NIC (NDIS 6.20)
       Physical Address. . . . . . . . . : 00-1F-BC-01-C9-2A
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.2.1(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :
       DNS Servers . . . . . . . . . . . : 192.168.2.1
       NetBIOS over Tcpip. . . . . . . . : Enabled


    /kj
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Rick Tan Monday, August 29, 2011 3:05 AM
    Wednesday, August 17, 2011 4:46 PM
  • Thanks very much for the input - I have to use a router to address a static DHCP IP to the PC as the connection itself is dynamic - which doesn't matter as I only need internal resolution - suppose I could only allow that one Ip to be addressed and see if I can disable anything else. Thanks I'll start heading in that direction.
    Thursday, August 18, 2011 7:07 AM