none
GPO or way to change "Use Automatic Configuration Script" 2008 R2

    General discussion

  • Afternoon all,

    We have recently changed our proxy server. We were using Websense and all users in their Internet Explorer LAN settings, had the " Use Automatic Configuration Script" enabled / ticked, and with a URL in there.

    We cannot find any group policy where this is defined, and to make matters more complicated because we are running Server 2008 R2 and Internet Explorer 11, we now have no way of overriding or changing this setting.

    Having googled this for some time all i can see is that we need to install the new RSAT tools on a Server 2012 R2 or Windows 8 machine, however we have no access to these operating systems, and there is no option in Internet Explorer for the Internet Explorer Maintenance, so now we are stuck with users getting an error each time they open Internet Explorer.

    Does anyone know a way we can make a group policy, or something to wipe out the tick and the wording from " Use Automatic Configuration Script"?

    Hope you can help, thanks

    Thursday, July 30, 2015 12:09 PM

All replies

  • Unfortunately when i go to control panel settings and then internet settings in GPO, i only get the option for IE 5 or 6, IE7 or IE8.

    I think this is do to with what i mentioned in my opening statement -  We are running Server 2008 R2 domain controllers and the clients all have IE11 so i cant use this option. Ive already found and tried the registry change item but this didnt work.

    I simply need to take the tick OUT of the box and UNTICK the item, i dont neccessarily care the wording written inside the option, as long as it is UNTICKED.

    Hope this makes sense, cheers

    Thursday, July 30, 2015 12:42 PM
  • Right, that is why I say use the GPP part of the article.  Use GPP to delete the 'AutoConfigURL' registry key.  Once the key is deleted, the check mark will be removed. 
    Thursday, July 30, 2015 12:52 PM
  • Thanks, we have now added that registy key to delete the item, it seems to have "ungreyed" the option but the option is still ticked and the wording is still in there.

    Is the option definitely "AutoConfigURL" as per the link you sent me? Cheers

    Thursday, July 30, 2015 1:26 PM
  • Can you search the registry for the wording and/or the AutoConfigURL key elsewhere in the structure?  Maybe it is in one of the policy hives.  But I thought it was only the key and yes it is AutoConfigURL, I tested it on my machine.

    If testing, make sure the user "Current User" is the same as the user opening IE. 

    If you put the previous settings in via Internet Explorer Maintenance, check this link for where it puts entries.

    https://technet.microsoft.com/en-us/library/Cc728403%28v=WS.10%29.aspx?f=255&MSPPError=-2147217396

    Thursday, July 30, 2015 1:34 PM
  • I believe this has solved the issue ( deleting the reg key via GPO )

    It seems to have actually greyed out the option, unticked it and removed the wording which suits us as nobody can edit the option and the wording is no longer there.

    Thanks for the assistance Vaadadmin

    Friday, July 31, 2015 11:47 AM