locked
Using Exchange properties to forward, and the "From" address displayed RRS feed

  • Question

  • If memory serves, I thought Exchange 2003, when you set the mailbox properties to forward to a user, showed the user account that was forwarding it as the "from" in the mailbox of whoever it was forwarded to.  This was one of the reasons some of my clients preferred that when they fired an employee, so they could immediately tell in their inbox what mail was forwarded to them that came in for the ex employee.  As opposed to removing the mailbox of the ex employee and simply applying their email address to the other person's mailbox so it would get delivered directly.

    One client that was used to this has been migrated to SBS 2011 so now they're on Exchange 2010.  I set up a forward from a mailbox to another mailbox via Exchange's console, and now it always shows the originating address as the "From" even after it was forwarded.  My searching has found a ton of people asking how to do this by default, and I can't find any posts about how to have it NOT do this by default.  There is no oulook involved here, so no outlook rules happening.  And I get this forward whether it's from someone in the GAL or someone outside of the company with no contacts for them.

    Is there some way that an email forwarded via the exchange properties will show the sender as the account doing the forwarding, as opposed to the original sender?

    Thanks for any suggestions.


    John

    Thursday, May 10, 2012 3:51 PM

Answers

  • Hi John,

    As far as I know, the Forward you set on Exchange mailbox, will not change the From address (just save the previous address).

    If you need the From address change to the address of forwarding mailbox, you can just follow Simon's suggestion, create forwarding rule in that mailbox, this way will change the From address.

    On Exchange 2010, you can create this rule in OWA:

    Apply to all messages

    Do the following...

    Forward the message to Administrator (user who need forward to)

    And stop processing more rules on this message

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support


    Friday, May 11, 2012 7:40 AM
    Moderator

All replies

  • The behaviour that you are seeing is what I would expect, even on Exchange 2003.

    It is one of the major flaws with the forwarding method on Exchange 2003 and higher when forwarding to an external account. As the from field is preserved it can appear that the Exchange server is spoofing and means email will be blocked by anyone doing strict antispoofing detection.

    The only way that might modify the header would be a forwarding rule in the mailbox.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    Thursday, May 10, 2012 5:05 PM
  • I'm curious how their old 2003 server they migrated off from did it then, since that one always showed the forwarder's email address, not the original sender's.  I also had the same thing on a 2003 at another company as well.  Those were the only two sites I ever had to set up forwarding like that for an ex employee though, but since they both behaved that way, I had assumed it must be default since I did nothing special to make it any other way.  Neither had any bizarre things added to the servers, or third party apps that I recall since I had built and maintained them both.  Doesn't mean there's not something I don't remember now though that was done that could have changed something, maybe an old spam engine or something I had removed years ago and forgotten they even used after I moved them to my barracuda...

    I'll play around then with a bogus account to see what I can do by temporarily using Outlook on the account to try a rule.  At least I know to stop wasting my time googling.

    Thanks!



    John



    John

    Thursday, May 10, 2012 5:27 PM
  • It wasn't Exchange doing it. Exchange doesn't rewrite the headers on a forward at the server level. It would change the from on a rule at the mailbox because the email is delivered, then forwarded.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    Thursday, May 10, 2012 10:35 PM
  • Hi John,

    As far as I know, the Forward you set on Exchange mailbox, will not change the From address (just save the previous address).

    If you need the From address change to the address of forwarding mailbox, you can just follow Simon's suggestion, create forwarding rule in that mailbox, this way will change the From address.

    On Exchange 2010, you can create this rule in OWA:

    Apply to all messages

    Do the following...

    Forward the message to Administrator (user who need forward to)

    And stop processing more rules on this message

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support


    Friday, May 11, 2012 7:40 AM
    Moderator
  • Took a couple attempts - first time there was no "forward" option.  Not until I created a redirect one could I then go back and edit it and see a further choice to forward.  Didn't know I had to hit More Options the first time to get it to give a submenu to allow an explicit forward.  But it works now.

    Thanks everyone.  Client is much happier now that things are back to how they are used to them.


    John

    Friday, May 11, 2012 12:49 PM
  • You are correct the behavior was changed after Ex 2003, the envelope header in 2003 would preserve the original sender, in 2007 going forward it will show the forwarded sender.

    http://exchangeshell.wordpress.com/2009/09/05/forwarding-exchange-2003-exchange-2007/


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, May 11, 2012 5:08 PM