none
Project Server 2016 reporting database Phase and stages table data is empty RRS feed

  • Question

  • Dear,

    Could anyone of you please help me on the below issue.

    I have configured a new Project Server 2016 Envt and observed that the following tables data is empty.

    • [pjrep].[MSP_EpmWorkflowStage]
    • [pjrep].[MSP_EpmWorkflowPhase]
    • [pjrep].[MSP_EpmWorkflowStatusInformation]

    And also I have verified the Phases and Stages information in Publish database and I can see the values in published database. This issue is there only for the above mentioned tables in reporting database.

    Do I need to run any command to fix this issue.

    Thanks,

    Venkat


    • Edited by VenkatraoP Wednesday, November 8, 2017 3:40 PM
    Wednesday, November 8, 2017 3:27 PM

Answers

  • Hahahhh!!!!!

    Amazing. Nice Reply :) :) :).

    However, I would like to tell you that in Project Server 2016, there are some views missing in Reporting DB and it is known issue and for this need to run the following command to fix.

    Repair-SPProjectWebInstance <PWA URL> -RepairRule 7 (Technet Article for reference: https://blogs.technet.microsoft.com/projectsupport/2016/07/08/project-server-2016-missing-some-userviews/)

    And I thought we might need to run some command to fix the following data tables issue as well.

    • [pjrep].[MSP_EpmWorkflowStage]
    • [pjrep].[MSP_EpmWorkflowPhase]
    • [pjrep].[MSP_EpmWorkflowStatusInformation]

    Thanks,

    Venkat


    Thursday, November 9, 2017 5:30 AM

All replies

  • yes bro. you can fix your error with a simple command from your keyboard. 
    Thursday, November 9, 2017 4:28 AM
  • Hahahhh!!!!!

    Amazing. Nice Reply :) :) :).

    However, I would like to tell you that in Project Server 2016, there are some views missing in Reporting DB and it is known issue and for this need to run the following command to fix.

    Repair-SPProjectWebInstance <PWA URL> -RepairRule 7 (Technet Article for reference: https://blogs.technet.microsoft.com/projectsupport/2016/07/08/project-server-2016-missing-some-userviews/)

    And I thought we might need to run some command to fix the following data tables issue as well.

    • [pjrep].[MSP_EpmWorkflowStage]
    • [pjrep].[MSP_EpmWorkflowPhase]
    • [pjrep].[MSP_EpmWorkflowStatusInformation]

    Thanks,

    Venkat


    Thursday, November 9, 2017 5:30 AM