none
Access Denied to Project 2010 PWA after SP1 and October2011 CU install RRS feed

  • Question

  • Hey everyone!

    I'm having an issue where i get an Access Denied message no matter what user i attempt to use to connect to my PWA site.  I have tried to change the site administrator through the Change Site Collection Administrators section.  I have also tried to edit the Project Web App site through the Project Service Application and change the administrator there, but it gives me an error:
    "The Project Web App path cannot be empty. Please enter a Project Web App path.
    The Project Web App Site path is invalid. Correct path and try again.
    "

    Our PWA site is at the root of the Web Application so the URL is: https://project/

    I even went into PowerShell and executed "Upgrade-SPProjectWebInstance -URL "https:\\project"".

    Then i still didn't get access so i tried to use the PowerShell commands to remove the project site administrator and after that failed to try to add a project site administrator, but that failed as well with the same error of: "UnauthorizedAccessException".

    Please help us get our Project Server back.  Thanks.


    • Edited by adam b99 Thursday, December 1, 2011 10:36 PM
    Thursday, December 1, 2011 10:35 PM

All replies

  • Hello Adam,

     

    Can you access https://project/_layouts/pwa/admin/admin.aspx page?

    Also verify the entry of /project under managed paths of web application

     

    Thanks,

    Hrishi Deshpande

    DeltaBahn LLC

     

    Friday, December 2, 2011 1:27 AM
    Moderator
  • Did you follow the recommendations after install all the CU ??

    Did you run the Sharepoint configuration wizard after you installed CU and SP1?

     

    Kind regards!


    Miguel Soler
    Friday, December 2, 2011 11:10 AM
  • No, i also get an access denied when trying to access the admin page directly via https://project/_layouts/pwa/admin/admin.aspx.

    Also, under the managed paths it lists (root) as an Explicit inclusion, so that means the root site is automatically added to the managed paths of the web application.

    Yes, i did run the configuration wizard after installing both the CU and SP1.  Also i guessed that project did not upgrade correctly, so i ran the powershell command i stated earlier to force an upgrade of the Project site.

    Please advise next steps.

    Thanks.

    Friday, December 2, 2011 2:47 PM
  • Hello Adam,

    Could you please run following query to verify the version of project dbs

    SELECT * FROM Versions

    WHERE VersionId ='00000000-0000-0000-0000-000000000000'

     

    For Oct 2011 CU, version should be 14.0.6112.5000

    Also use the same query to run against any SharePoint databases, version ID should be + or – few numbers of project database.

    Above steps is to validate conflict of db versions between SharePoint and Project

     

    Thanks,

    Hrishi Deshpande

    Sr Consultant @ DeltaBahn LLC

     

    Friday, December 2, 2011 7:45 PM
    Moderator
  • First thing I would check,  would be under the Central Administration, Manage Service Applications, Project Server Application, how is the status of your PWA applicaction...

    Could you share that information?

     

    Kind regards!


    Miguel Soler
    Saturday, December 3, 2011 2:34 PM
  • Hrishid, I ran that query on both databases and the last result for both databases have a Version of 14.0.6112.5000.  So, it looks like they are both to the same version.

    Miguelet, I did check that in Central Admin and i guess i must have forgot to mention it earlier.  It says, "Provisioned, with errors - see the Application event Log".  However, there is nothing in the event log pertaining to this, so i don't know why it errored.  I'm guessing this is at least important, so please let me know how i can figure out what the errors are and how to resolve them.  Thanks.

    Adam

    Monday, December 5, 2011 3:35 PM
  • Hello Adam,

    In Central admin, on PWA status page when you click on the status do you get retry option?


    Thanks,
    Hrishi

    Monday, December 5, 2011 3:51 PM
    Moderator
  • Hi adam again,

    As the application says, see the Application event log. Try to enter to the application PWA and how we know, you will not enter, but in this moment you can search up in the ULS logs for some information about what is happening.

    You can try to re-provision your PWA. The key is close!

     

    Let us know your results!!


    Miguel Soler
    Monday, December 5, 2011 3:56 PM
  • Hrishid, No there is not a retry option for provisioning the PWA.

    Miguelet, i have checked the Application event log and have tried checking the ULS logs, but perhaps i am not checking the ULS logs on the correct server.  I have 2 WFEs and 2 App servers.  Do you know which server i should be checking the ULS logs on when i try to connect?  Any particular logs that i should be looking for in the ULS logs?

    Let me know

    Adam

    Monday, December 5, 2011 4:25 PM
  • I would check the logs where the Project Server service application is activated...

     

    Cheers!


    Miguel Soler
    Monday, December 5, 2011 5:44 PM
  • Well, we have the Project Server service started on both App servers.  So i ran ULS Viewer on both while i tried to access the PWA, and i did not see any errors that looked like they were from Project.  All i got was an error like:

    The Execute method of job definition Microsoft.SharePoint.Diagnostics.SPSqlBlockingReportDiagnosticProvider (ID 019b2256-3439-40bd-b9d4-6d64cbbc88a5) threw an exception. More information is included below.  The blocking query diagnostics provider could not set the 'blocked process threshold' for the sql instance srv-mssql2\mssql2.  Blocking queries will not be captured in this instance.  Error Code: User does not have permission to perform this action.  You do not have permission to run the RECONFIGURE statement.  The configuration option 'blocked process threshold' does not exist, or it may be an advanced option.  You do not have permission to run the RECONFIGURE statement.

    and

    The Execute method of job definition Microsoft.SharePoint.Diagnostics.SPSqlDeadlockDiagnosticProvider (ID 90bfd417-b706-4c00-972a-be7c4f53b92a) threw an exception. More information is included below.  You do not have permission to run 'SP_TRACE_CREATE'.

    However, those both look to be from the diagnostics stuff, and not anything to do with Project.

    Please let me know if there is anything i can filter by or anything to get any more information.

    I did see the following logs from the Microsoft.Office.Project.Server service:

    12/05/2011 13:53:47.57	Microsoft.Office.Project.Server (0x0930)	0x0A9C	Project Server	Provisioning	8zdn	Medium	[SERVICE] ProjectEventService14: Getting list of Sites for ServiceApp: eba9a626-d1ad-41aa-9621-f0c5de0da4f7	
    12/05/2011 13:53:47.57	Microsoft.Office.Project.Server (0x0930)	0x0A9C	Project Server	Provisioning	128v	Medium	[SERVICE] ProjectEventService14: Adding Site: 02d4f70e-8b8c-4cbd-b366-df0e53305f43 to sitelist for ServiceApp: eba9a626-d1ad-41aa-9621-f0c5de0da4f7	
    12/05/2011 13:53:47.57	Microsoft.Office.Project.Server (0x097C)	0x0A98	Project Server	Provisioning	8zdn	Medium	[SERVICE] ProjectQueueService14: Getting list of Sites for ServiceApp: eba9a626-d1ad-41aa-9621-f0c5de0da4f7	
    12/05/2011 13:53:47.57	Microsoft.Office.Project.Server (0x097C)	0x0A98	Project Server	Provisioning	128v	Medium	[SERVICE] ProjectQueueService14: Adding Site: 02d4f70e-8b8c-4cbd-b366-df0e53305f43 to sitelist for ServiceApp: eba9a626-d1ad-41aa-9621-f0c5de0da4f7	
    

    But those look normal and free from errors.  Please help.  Thanks.

    Adam

    Monday, December 5, 2011 8:01 PM
  • Seems dummy question, but did you check the status of the databases from Central Administration, Upgrade & Migration option?

    Your logs are normals, yes. We are looking for something failed in your logs, and you just post the most normal...

    Try to enter into your PWA, and at the same time, capture the logs trying to retrive some more information...

     

    Kind regards!


    Miguel Soler
    Monday, December 5, 2011 10:54 PM
  • Miguelet-

    Sorry if i posted normal logs, but that is the only logs which were flagged in ULS or even mentioned the Project PWA when i tried to access the site.

    Please give me more information as to what to do if i am missing something here.  I am trying to supply as much information as possible to try to get this resolved since we had live data in the project PWA site and now no one can access the site, even the farm administrator or site administrator or any other user account i can think of.

    Do you want me to post the entire ULS logs from the server when i attempt to connect?  That would be a very long post and will probably not be useful just like my last post since they seem to be pretty normal as you said.

    Let me know what i can do to help resolve this problem.

    Thanks.

    Adam

    Wednesday, December 7, 2011 3:23 PM
  • Oh, and the databases are fine, none of them need to be upgraded.  They all Succeeded.

    Adam

    Wednesday, December 7, 2011 4:13 PM
  • Ok Adam,

     

    Another point. This week in a new environment we had problems to create a PWA instance, and received the same error as you "Provisioned, with errors - see the Application event Log".

    This message was generated with the try of  part of a partner and, as Hridhid said, we use the Retry option from the drop-down menu in the Project Server service Application and, of course we received the same message too, but in that moment we monitored the ULS information and encountered that the problem was becaming for a lack of free space in SQL Server.

    Cheers!


    Miguel Soler
    Friday, December 9, 2011 8:02 AM
  • That is great that you had a "Retry" option, but there is not that option for us.  We only have View, Edit, and Delete.  So, there is no way for us to retry the provisioning.  However, as i said before, this PWA was working previously and does have active data in it.  So we want to make sure we do not destroy any data by re-provisioning or anything like that either.

    Any more suggestions?

    Thursday, December 15, 2011 4:33 PM
  • I think you can try Edit and then retry or ok option something like that on edit page

     

    Hrishi

    Thursday, December 15, 2011 7:15 PM
    Moderator
  • If you take a look at my initial post, whenever i try to edit the PWA and click OK, it gives me that error and therefore cannot modify anything on the PWA.
    Thursday, December 15, 2011 7:57 PM
  • Adam,

     

    Please install the December 2011 CU http://support.microsoft.com/kb/2596997, and keep a look on your ULS.

    If your PWA will not start, examine your ULS in detail. May be you will get an answer or a clue about the problem.

     

    Best regards!


    Miguel Soler
    Thursday, December 15, 2011 9:36 PM
  • Dont know if this is still an issue, but have you actually looked at the UPGRADE log. When you run PSCONFIG, after a CU / SP install items will be written to that log.

     

    Andre


    http://av-epm.blogspot.com
    Thursday, December 22, 2011 8:01 AM
  • Well, yes this is still an issue and i just checked my upgrade logs and the only errors i found were when i tried to initially run the Project upgrade command from Powershell after i saw this issue.  That was because the user i was logged in with did not have access to the Project DB, but i fixed that and ran it again and it completed without any errors.  I also verified the versions of both the databases as Hrishi suggested earlier.  So they are both upgraded to the same SP and CU.

    I don't even know for sure if this is an SP or CU issue since i did not personally validate that project was working prior to upgrading, and i was never told if there was an issue with project prior to upgrade.

    I was able to try a db attach to a new PWA site that i created in the exact same way.  Here is what i did:

    1. Copy the Project DB to new DB name
    2. Create new Web Application
    3. Create new PWA site at new Web App using the same method as the original site.
    4. Test site (It worked just fine and i was able to log in)
    5. detach content database from new Web App
    6. Attach old database to new web app
    7. Attempt to access site (it did not work and actually gave me a 404 not found error)

    Let me know if anyone has any more ideas.  Thanks.

    Tuesday, December 27, 2011 3:40 PM
  • Hi Adam,

     

    Thanks for the update. I was thinking about the same option (Re-provisioning of PWA).

    Step number 5 is incorrect, you should not detach the content database  after provisioning PWA, correct steps would be

     

    1. Create new web app using dummy content database

    2. Detach dummy content database and attach old content database

    3. Try to provision PWA site (same name as old), this will help to avoid bulk update option to sync workspaces.

     

    Thanks,

    Hrishi Deshpande

     

     

    Tuesday, December 27, 2011 3:49 PM
    Moderator