none
Error: One or more categories of approval could not be loaded when user wants to approve RRS feed

  • Question

  • Hi, We have got one user in Project Server 2010 with this error:

    Error: One or more categories of approval could not be loaded

    He can approve administrative time (Leave, ex) but not normal worked hours

    The Approval list is empty with the error above in the bar across the screen.

    On his home page it shows that he has got 20 task updates from resources.

    The rest of the users can approve.

    This was working...

    Wednesday, March 30, 2011 7:38 AM

Answers

All replies

  • We are still having this issue... the issue must be with the category for timesheets... How can i trouble shoot this?

     

     

    Friday, April 1, 2011 10:37 AM
  • Our Approval center just started exhibiting this behavior as well.
    Friday, April 1, 2011 2:00 PM
  • trying to log a call with Microsoft but they dont get back to me...Trying to phone them again now but cant get threw...

     

    Friday, April 1, 2011 2:12 PM
  • We created a rule to automatically approve the offending items, this fixed the issue. We do not know what caused it.
    Friday, April 1, 2011 4:16 PM
  • How do you do that?
    Friday, April 1, 2011 5:00 PM
  • In the Approval Center, you should see (at least as an administrator) the manage rules section at the top "Navigate" section.
    Friday, April 1, 2011 5:53 PM
  • Ok, that wil sort it for now but not a permanent solution...

    Any other ideas will help.

    Tuesday, April 5, 2011 7:12 AM
  • I got this error when I had a task update from a resource with a REALLY big number for actual hours.

    By looking at the ULS logs I saw that the number exceeded the limit. For our purpose we are trying to enter BIG numbers into actual, tens of thousands of hours into a single day. It looks like MS Project Server can only handle a number that is less than an INT32 can handle * 60000. We need this fixed from MS. The problem seems to be in the page that displays the hours to approve for the PM, since it displays just fine for the resource that entered the hours on his task update screen.

     

     

    Tuesday, September 20, 2011 5:11 AM
  • I've had this issue occur twice.

    Once with a customer, where we used the approval rule workaround to accept all updates. The issue hasn't occurred again, and we do not know what caused it.

    Another time, the issue occurred for me. A colleague had created a task for herself in PWA on a project of mine. Another project manager had then saved and published the task, and I had the error in the approval centre.
    Afterwards, I opened the plan, made changes, saved, published, and the approval centre seemed to have worked again. Correlation or even causation? I cannot tell, just posting anecdotal data since nobody seems to have any handle at all.

    Kind regards,
    Adrian

    Wednesday, March 28, 2012 12:25 AM
  • Regarding the Error: One or more categories of approval could not be loaded when user wants to approve

    We have the same issue with a plan of 261 lines, a rather normal MS Project Plan.  When in Approval Center, the view does not allow to click on any of the menu possiblities, hence not "Manage rules", and noone has entered any big number into the plan recently.

    No matter how many times the plan is published, the same error message comes up, and the approver is not able to approve any tasks.

    Anything more we can try to get rid of this error message?

    Regards,

    Heidi

    Wednesday, May 16, 2012 12:28 PM
  • I faced a similar one. All i did was to open the project in MSP and then change the status manager A to status Manager B who has PM rights or an Admin. Publish the project. Check the Approval Center for Status Manager B and all the tasks can be seen in the Approval Center. You can accept those changes there or again change the status manager to A and publish. Check the Approval center again. Hope this helps.


    Cheers, Amit Wairkar

    Monday, August 6, 2012 12:24 PM
  • Hi All,

    I have very similar issue with one of my user's timesheet Approval.

    Can someone please advise how do I find the culprit timesheet line so that I can recal or edit the project.

    Thanks

    Monday, May 6, 2013 8:17 AM
  • Hi All,

    I was able to identify the Timesheet that was causing the issue by comparing Timesheet Manager's Timesheet Approval History and Submitted Timesheets in Timesheet Lines table in database.

    Then I recalled the timesheet of that perticular user, and the issue was resolved. Submitting again the timesheet did not reproduce the issue.

    Thursday, May 16, 2013 6:59 AM
  • This is a known bug - see this thread for the workaround without disabling single entry.

    Cheers,

       James.


    James Boman - http://www.boman.biz Software Consultant for IPMO - http://www.ipmo.com.au

    Tuesday, January 21, 2014 10:18 PM