locked
[AppV 5.0] Starting Firefox as a default application via Start - Run RRS feed

  • Question

  • Hello all,

    I have sequenced Mozilla Firefox 17 with AppV 5.0 sequencer on Windows 7 SP1 Enterprise. If I deploy the application to a Windows 7 SP1 Enterprise computer, I am unable to start Firefox if I type in an URL in the Run box. Internet Explorer is started instead of Firefox.

    The application has been deployed as follows:

    Set-ExecutionPolicy -ExecutionPolicy Unrestricted
    Import-Module AppVClient
    Add-AppvClientPackage –Path D:\Mozilla_Firefox_17.0.1-AppV5.0_ENG\Mozilla_Firefox_17.0.1-AppV5.0_ENG.appv -DynamicDeploymentConfiguration D:\Mozilla_Firefox_17.0.1-AppV5.0_ENG\Mozilla_Firefox_17.0.1-AppV5.0_ENG_DeploymentConfig.xml | Publish-AppvClientPackage -Global

    My question is: what do I have to do to start Firefox if I type in an URL in the Run box?

    Your help is appreciated and with kind regards,

    Willem-Jan

    Friday, January 4, 2013 6:22 PM

Answers

  • Hello all,

    I have it working.

    After setting Firefox as the default browser, I went to 'Default programs' in the Control Panel. Then I was able to set Firefox as the default program for all protocols and file extensions.

    If someone knows a better solution: please let me know.

    With kind regards,

    Willem-Jan

    • Marked as answer by WillemPiloot Monday, January 7, 2013 8:53 AM
    Monday, January 7, 2013 8:52 AM

All replies

  • Hello,

    Firefox needs to be set as the default browser. See this guide;

    http://support.mozilla.org/en-US/kb/how-make-web-links-open-firefox-default

    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, January 4, 2013 6:34 PM
  • Type in the run box:

    firefox url.com

    substituting of course your url for url.com


    V Wood Binghamton, NY

    Friday, January 4, 2013 8:02 PM
  • Hello,

    Next Monday I will have a look at my work. I will try both solutions.

    Have a nice weekend and thanks for the help.

    Willem-Jan

    Saturday, January 5, 2013 10:07 AM
  • Hello all,

    My findings:

    • I have set Firefox as the default browser: if I go to start ->search box and type in 'www.google.com' then Google is opened in IE instead of FF.
    • If I type in 'firefox www.google.com' then google is opened with FF.
    • If I enable 'Run' in the 'Customize Start Menu' and type in 'www.google.com' then Google is opened with IE instead of FF.
    • If I check the settings from IE, under 'Programs' still IE is marked as the default browser. Weird...

    What am I doing wrong?

    With kind regards,

    Willem-Jan


    • Edited by WillemPiloot Monday, January 7, 2013 8:31 AM Added 4th point.
    Monday, January 7, 2013 8:27 AM
  • Hello all,

    I have it working.

    After setting Firefox as the default browser, I went to 'Default programs' in the Control Panel. Then I was able to set Firefox as the default program for all protocols and file extensions.

    If someone knows a better solution: please let me know.

    With kind regards,

    Willem-Jan

    • Marked as answer by WillemPiloot Monday, January 7, 2013 8:53 AM
    Monday, January 7, 2013 8:52 AM