none
Issue with Set-adaccountpassword RRS feed

  • Question

  • I have tried to reset the password for account which is in different domain by using set-adaccountpassword cmdlt but it not allowing me to reset it.

    Here the script i used

    Set-ADAccountPassword -name redmond -Identity skur -OldPassword (ConvertTo-SecureString -AsPlainText "password@dfejw" -Force) -NewPassword (ConvertTo-SecureString -AsPlainText "rwwjebrwebb@1254" -Force)

    here domain - redmond

    account name :skur

    can you some some correct me if i am wrong

    Wednesday, April 8, 2015 10:52 PM

Answers

  • Hi There,

    The cmdlet parameters appear to be incorrect. There is no -name parameter in the Set-ADAccountPassword cmdlet.

    Instead, you could try:

    Set-ADAccountPassword -Server <name of a redmond dc> -Identity skur -OldPassword 
    (ConvertTo-SecureString -AsPlainText "password@dfejw" -Force) 
    -NewPassword (ConvertTo-SecureString -AsPlainText "rwwjebrwebb@1254" 
    -Force)

    You'll need to set the <name of a redmond dc> to the host name of one of the DCs for this domain.

    HTH

    • Proposed as answer by jrv Wednesday, April 8, 2015 11:08 PM
    • Marked as answer by Bill_StewartModerator Saturday, April 25, 2015 3:22 AM
    Wednesday, April 8, 2015 11:04 PM

All replies

  • You will have to bean admin in the other domain and connect to a DC in that domain.  Use -server to use a DC in the remote domain.


    \_(ツ)_/

    Wednesday, April 8, 2015 10:58 PM
  • Hi There,

    The cmdlet parameters appear to be incorrect. There is no -name parameter in the Set-ADAccountPassword cmdlet.

    Instead, you could try:

    Set-ADAccountPassword -Server <name of a redmond dc> -Identity skur -OldPassword 
    (ConvertTo-SecureString -AsPlainText "password@dfejw" -Force) 
    -NewPassword (ConvertTo-SecureString -AsPlainText "rwwjebrwebb@1254" 
    -Force)

    You'll need to set the <name of a redmond dc> to the host name of one of the DCs for this domain.

    HTH

    • Proposed as answer by jrv Wednesday, April 8, 2015 11:08 PM
    • Marked as answer by Bill_StewartModerator Saturday, April 25, 2015 3:22 AM
    Wednesday, April 8, 2015 11:04 PM
  • Yup. Missed that.

    \_(ツ)_/

    Wednesday, April 8, 2015 11:08 PM