none
RWA port redirection problem RRS feed

  • Question

  • Hi,

    I have a problem with a new  Windows Server 2012 Essentials R2 install. I am having problems with RWA/Anywhere access.

    Here is some useful info

    Windows Server Essentials 2012 R2 is at IP 192.168.1.3

    Router is a sonicwall TZ100W GW= 192.168.1.1

    Customer Portal PC is in a DMZ  192.168..10.9

    I am making up a domain name to protect customer.  www.clubexample.com

    We have a GoDaddy SSL Cert for remote.clubexample.com

    Here is Problem:

    There is an existing use of HTTPS port  443 box for a customer portal pc. With old setup.  So all traffic for https port 443 is forwarded to Customer Portal PC @ 192.168.10.9.

    So in the sonicwall have setup rule that all traffic for port 446 be sent to port 443 on the Windows Server Essentials R2 @ 192.168.1.3.

    This  done with a link for remote user like this.

    https:/remote.clubexample.com:446/remote

    We get to RWA login and are able to login.  We get the launch pad for Devices/Shared Folders/Links.

    Everything works right except Devices when we click on pc to access. We get:

    Window: Remote Desktop Connection

    Your computer can’t connect to the remote computer because the Remote Desktop Gateway server address requested and the certificate subject name do not match. Contact your network administrator for assistance.

    View certificate shows a  a GoDaddy Certificate issued to:

    members.clubexample.com

    I assume this is the customer portal in DMZ?

    Side Note:

    If customer portal is disabled and port 443 is sent to normal location at WSE it works fine.

    Any ideas?

    Thanks

    Dexter  Southerland  

    Monday, February 22, 2016 4:27 PM

Answers

  • You should get more Internet rout-able IP addresses. I assume you have one at the moment. If you have more then one and your router can deal with that you can forward traffic for both sites on port 443.

    Mariëtte Knap
    www.server-essentials.com | Linkedin | Twitter | Facebook

    Monday, February 22, 2016 7:27 PM
  • Hi,

    Essentials server simplified deployment via integrated Wizard, such as Set Up Anywhere Access, related configurations(certificate, DNS record, port and etc.) are automatically configured by this Wizard.

    As you mentioned that Remote Desktop Connection does not work after manually changing port 443 to 446.

    I would recommend to reference Mariette’s suggestion to have another public IP address, or, consider of redirecting port of the Customer Portal PC.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, February 23, 2016 9:32 AM
    Moderator

All replies

  • Hi,

    Essentials server simplified deployment via integrated Wizard, such as Set Up Anywhere Access, related configurations(certificate, DNS record, port and etc.) are automatically configured by this Wizard.

    As you mentioned that Remote Desktop Connection does not work after manually changing port 443 to 446.

    I would recommend to reference Mariette’s suggestion to have another public IP address, or, consider of redirecting port of the Customer Portal PC.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, February 23, 2016 9:32 AM
    Moderator
  • Eve,

    I am going to recommend the two options recommended. Do you know any other solutions. I am assuming you have high confidence in these 2 solutions? Just asking. Customer is not very forgiving.

    Thanks for Help :)

    Dexter

    Wednesday, March 9, 2016 4:12 PM
  • Mariette,

    I am going to recommend the two options recommended. Do you know any other solutions. I am assuming you have high confidence in these 2 solutions? Just asking. Customer is not very forgiving.

    Thanks for Help :)

    Dexter

    Wednesday, March 9, 2016 4:13 PM