locked
WSS + SSRS: Report viewer = 401 unauthorized unless on ssrs local machine RRS feed

  • Question

  • I have a ssrs running in integrated mode. I'm using kerberos authentication. I can browse the report server directly from anywhere. I can browse the wss site without issue from anywhere. However, when I navigate to a wss page, unless I'm on the ssrs local machine the report viewer control renders an error:

        The request failed with HTTP status 401: Unauthorized.

    How do I troubleshoot from here?

    Edit:

    I've also checked the event logs, sharepoint logs, and ssrs logs with no luck. Seems like nothing is going wrong...

    Edit 2:

    Adding the wss site to 'trusted sites' resolved the issue for internal network clients. But the issue remains for external clients coming in through an ISA WSS publishing rule. Seems like a kerberos issue.

    Wednesday, December 8, 2010 2:06 AM

Answers

  • Hi,

     

    Configure Kerberos authentication, and then configure SharePoint to correctly use Kerberos authentication. (The overall configuration of Kerberos is documented in a large number of other resources and won't be specifically covered here. The following steps assume Kerberos has already been configured correctly. For more information about Kerberos and troubleshooting, see section 10.2, “Kerberos.”)

    a.        After Kerberos is configured, change the authentication providers on the SharePoint sites in order to be able to successfully use Kerberos.

    b.        Open Central Administration, and then click Application Management.

    c.         Under Application Security, click Authentication Providers.

    d.        Click the zone you want to modify.

    e.        Under IIS Authentication Settings. click Negotiate instead of NTLM.

    f.          Click Save.

    g.        Repeat steps iv-vi for each zone/site you want to change by selecting a different Web application from the drop-down list in the upper right hand corner

     

    I wish you every success in your important work.

    Best regards,

    David Hu

     

    • Marked as answer by Peng Lei Thursday, December 16, 2010 8:38 AM
    Friday, December 10, 2010 2:01 AM