locked
How to hide SPRibbon in Sharepoint 2010 master pages? RRS feed

  • Question

  • I have created a customized master page, its a Welcome Page.

    I have stucked with a problem. I hided all content place holder which is not necessary to me except SPRibbon.

    How to hide SPRibbon in Sharepoint 2010 master pages?

    Friday, March 22, 2013 8:30 AM

Answers

  • Hi,

    >but only the color of the ribbon changed to white.

    It is working fine in my environment. Have you check in and published and approve your master page after make above changes? if not then do so.

    > If i want to use SPSecurityTrimming in permission string what should i give

    In the link, you can see the permission as well. Just go to site settings-->site permission -->click on "permission level"-->click add permission level-->now select manage permission. Now you can assign same permission to your user or group.

    Now go to your master page and keep same permission string as mention in link. It should work and user who are having this permission, they can see the ribbon only.

    Hope it could help


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Please feel free to unmark answer if does not resolves your problem.

    • Marked as answer by Entan Ming Thursday, March 28, 2013 11:20 AM
    Friday, March 22, 2013 9:22 AM

All replies

  • Hi,

    Open you master page in designer and search for

    <div id="s4-ribbonrow" class="s4-pr s4-ribbonrowhidetitle">

    Change this to:

    <div id="s4-ribbonrow" class="s4-pr s4-ribbonrowhidetitle" style="display:none">

    If you want to keep ribbon for some user then use SPSecuritytrimming as per below blog:

    https://www.nothingbutsharepoint.com/sites/eusp/Pages/hiding-the-sharepoint-2010-ribbon-from-anonymous-users.aspx

    Hope it could help


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Please feel free to unmark answer if does not resolves your problem.

    Friday, March 22, 2013 9:03 AM
  • @Hemendra: Thank u. I already gave display:none in that div.

    but only the color of the ribbon changed to white.

    I want to hide ribbon for all users, because its a welcome page. If i want to use SPSecurityTrimming in permission string what should i give? Thanks.

    Friday, March 22, 2013 9:10 AM
  • Hi,

    >but only the color of the ribbon changed to white.

    It is working fine in my environment. Have you check in and published and approve your master page after make above changes? if not then do so.

    > If i want to use SPSecurityTrimming in permission string what should i give

    In the link, you can see the permission as well. Just go to site settings-->site permission -->click on "permission level"-->click add permission level-->now select manage permission. Now you can assign same permission to your user or group.

    Now go to your master page and keep same permission string as mention in link. It should work and user who are having this permission, they can see the ribbon only.

    Hope it could help


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Please feel free to unmark answer if does not resolves your problem.

    • Marked as answer by Entan Ming Thursday, March 28, 2013 11:20 AM
    Friday, March 22, 2013 9:22 AM