locked
IE11 Behavior with failed intranet zone automatic logon RRS feed

  • Question

  • Hi,

    With a particular internal site in IE9 when the site is in the intranet zone and automatic logon fails we are prompted with a windows security Window to enter alternative credentials to log in.

    With IE 11 the security prompt never appears, the logon fails and the site reports back "You are not authorized to access this page" but there is no opportunity to enter alternate creds...

    On both versions the site is correctly placed into local intranet zone and so does attempt a logon.  I've tried both compatibility mode and enterprise mode, the behavior is the same.  I have also tried forcing the page into Internet and Restricted zones but this makes no difference.

    Any ideas?

    Thanks

    Friday, May 30, 2014 2:11 PM

Answers

  • I've tried all the strings and all the document modes, same result.

    It still sounds like a problem with the host.  Trace both cases to see if that is not the case.  Both IE9 and IE11 have Network capture in their Development Tools (F12) but the UI is different for each.


    Robert Aldwinckle
    ---

    • Marked as answer by Karen Hu Monday, June 9, 2014 1:46 AM
    Monday, June 2, 2014 3:38 PM
    Answerer

All replies

  • Hi,

    So we are connecting an internal site here?

    Please take a check with your permissions, and also please verify if any code issues are related (things like " convert to string " " permission to connect the DB files").

    In addition, please take a try to change the document mode and the user agent string in IE11 both to IE9, and then check the results. (F12 tool)

    Best regards


    Michael Shao
    TechNet Community Support


    • Edited by Michael_LS Monday, June 2, 2014 7:20 AM
    Monday, June 2, 2014 7:13 AM
  • Hi,

    So we are connecting an internal site here?

    Please take a check with your permissions, and also please verify if any code issues are related (things like " convert to string " " permission to connect the DB files").

    In addition, please take a try to change the document mode and the user agent string in IE11 both to IE9, and then check the results. (F12 tool)

    Best regards


    Michael Shao
    TechNet Community Support


    Hi,

    Yes it is an internal site, but it is actually just a device (UPS) so there is no access to any kind of code or config.  I've tried all the strings and all the document modes, same result.

    Thanks

    Monday, June 2, 2014 8:09 AM
  • I've tried all the strings and all the document modes, same result.

    It still sounds like a problem with the host.  Trace both cases to see if that is not the case.  Both IE9 and IE11 have Network capture in their Development Tools (F12) but the UI is different for each.


    Robert Aldwinckle
    ---

    • Marked as answer by Karen Hu Monday, June 9, 2014 1:46 AM
    Monday, June 2, 2014 3:38 PM
    Answerer