none
Attaching Items When Creating New List Items

    Question

  • Hi,

    In Office 365, it was possible to attach items when creating new list items (using the 2013 UI):

    However, it is currently not possible using the 2016 UI. The lists have attachments enabled and still allow attaching items to existing list items (by editing the existing items):

    Browsers used for testing: Chrome, IE 11

    I would like to know if there are any settings that must be configured, or if this is by design in 2016. Thank you

    Tuesday, November 29, 2016 2:29 AM

All replies

  • Hi Alexander,

    Per my test, I can see the Attach File tab when creating new list items in SharePoint 2016 list.

    For your issue, I suggest you create an new list, and navigate to list settings->Advanced settings->Enable attachment to the list items:

    If the issue still exists, try to open your list with another browser and compare the results.

    Add item with another user who have full control on the list and compare the results.

    Make sure there is no code which disable the tab.

    Navigate to the web part page maintenance page (eg: http://app/Lists/List022/NewForm.aspx?contents=1), Make sure there is only ListFormWebPart.

    Best Regards,

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, November 30, 2016 5:44 AM
    Moderator
  • Thank you for the update.

    Unfortunately, creating a new list with Attachments enabled still does not allow attaching files when creating a new list item

    

    I have searched other Microsoft forums, and it seems that this is applicable to the 2016/Modern Office 365 UI in general (and not an isolated incident). Below are links to threads with the same issue:

    SharePoint Online Modern Lists Add Attachments link missing on Add

    Suggestions have also already been raised on SharePoint UserVoice:

    Restore attachment option on new form in Lists (new experience)

    Ability to add an attachment when creating a list item in new experience

    I believe that it is already an issue for MSFT Engineering. Thank you for the response.

    Thursday, December 1, 2016 5:52 AM
  • Issue has been resolved as of the time of this post
    Monday, December 5, 2016 1:05 AM
  • Hi Alexander,
    I have done a test in my SharePoint online and I cannot reproduce your issue.
    When I add an new item from new experience, I can see the "Add attachments":

    Best Regards,
    Lisa Chen

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, December 6, 2016 12:47 PM
    Moderator
  • Hi Alexander,

    Since your issue is solved, please remember to mark your reply as an answer.

    Best Regards,

    Lisa Chen


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, December 8, 2016 1:13 AM
    Moderator