locked
Weird Win10 Hyper V Networking Issue RRS feed

  • Question

  • Hi, i have the weirdest problem i can't get to the bottom of.

    I have an internal network switch setup in hyper-v.

    I have a windows server running as a test in hyper v that's dealing with DNS/DHCP for a web environment test. So ideally i'd also like my host to have access to this network for copying files, rdp and testing websites. 

    The problem is, when i enabled the Hyper-V network adapter on my local machine for the internal only network, everything goes to S**t. even though i've set the interface metric to 1000 and my LAN adapter to 1 whenever for example I try to login to something on my production domain it takes like 3/4 minutes for the login dialog to popup. The RSAT tools are the worst though, if i open up AD users/computers it takes around 2 minutes to pop up at all. But doing the same tests without the network adapter enabled on my host it works perfectly as it should and loads in seconds.

    My host for the Hyper-V adapter only has an IP,Subnet and DNS. No router defined.

    The subnet is 255.255.255.0 and doesn't overlap any other subnet on my LAN.

    Any ideas?


    Tuesday, November 7, 2017 7:48 AM

All replies

  • Please provide the text output from the ipconfig /all command.  It is difficult to troubleshoot networking issues when the network configuration is not provided.


    tim

    Tuesday, November 7, 2017 12:41 PM
  • Hi DeliciousPoo,

    1. Please check if you enabled advanced features like VMQ, IR-SOV on the physical adapter on the hyper V host. If yes, please disable the features and test the result;

    2. Please check if the win10 hyper V host installed the latest windows updates, also check if the physical network adapter driver is up to date, try to update the NIC driver, check if it could help;

    3. You may also try re-create the Internal VSwitch, check if the issue remains.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 9, 2017 7:25 AM
  • Hi DeliciousPoo,

    Just to check if the above reply could be of help, if yes, you may mark useful reply as answer, if you have other concerns, welcome to feedback.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 10, 2017 3:05 AM
  • Hi DeliciousPoo,

    Have you get any progress with the issue? We are looking forward to your feedback.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 14, 2017 2:18 AM