locked
CentOS 7 VM's losing disk after Live Migration RRS feed

  • Question

  • Hi!

    CentOS 7 VM's are losing disks after live migration (node1 to node2). I have to reset VM to get them back. After research I can say that problem occured with latest kernel. When I rebooted with old kernel, Live Migration did not cause problems.
    Old kernel: 3.10.0-229.1.2.el7 - OK
    New kernel: 3.10.0-229.14.1.el7 - PROBLEM

    Hyper-V: Windows Server 2012 R2 (Latest important patches installed).

    Can anyone test it? How could I fix it?

    Thursday, October 1, 2015 6:01 AM

All replies

  • Hi,

    We have the same problem with CentOS 7 and HyperV 2012. This issue came with kernel-3.10.0-229.7.2.el7.x86_64 -kernel and it is because of some changes with storvsc (or something, don't know exact details.). Anyways, bug has been reported to RedHat and hopefully it is fixed on next kernel update.

    -juha

    Tuesday, October 6, 2015 11:00 AM
  • We are investigating this issue and will get back once we have identified a solution.

    Thanks, --jrp


    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    Monday, October 12, 2015 8:07 PM
  • Juha, can you provide the bugzilla number for my reference? If we identify solutions we will add them to the bug report.

    Thanks, --jrp


    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    Monday, October 12, 2015 8:11 PM
  • Hi Joshua,

    It should be this one, cannot verify it as I do not have access to it.

    #1267940

    -juha

    Monday, October 19, 2015 8:15 AM
  • Ok, good, that's one we are tracking. Thanks! --jrp

    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    Tuesday, October 20, 2015 4:31 AM
  • New kernel for CentOS came out, but it did not fix the problem.
    Thursday, November 5, 2015 8:19 AM