locked
Windows 8 mail app - No Sender, No Subject, RRS feed

  • Question

  • My outlook.com account in the new Windows 8 mail app has what appears to be 10 emails with the Sender/Message header of No Sender/No Subject. They are all blank, and cannot be moved or deleted. I've tried logging in without using my Microsoft account to see if the account would reset, but no luck.

    Is there a way to clear these blank "messages?"

    Paul

    • Moved by David Wolters Tuesday, May 21, 2013 1:50 PM Moving to a more appropriate forum
    Tuesday, November 6, 2012 1:57 AM

Answers

  • This is a problem with the mail app data store.  I deleted the mail folder from windows explorer (see path below) but that didn't help.  I deleted the entire windowscommunications... folder and that was bad (locked up windows).

     

    "C:\Users\ttirr_000\AppData\Local\Packages\microsoft.windowscommunicationsapps...

    \LocalState\Indexed\LiveComm\xxxxx...\xxxxx...\"

     

    I fixed this problem by uninstalling the mail app (includes people, calendar, messenger).  Be sure that your mail, appointments, etc. is backed up.  If you are syncing with outlook.com or Hotmail.com or exchange or an imap account you shouldn't have to worry.  You can just re-sync the accounts.  If you are using a pop server then you need to back up.

     

    Next just reinstall the mail, people, calendar, messenger app.  Your accounts should still be there you just need to configure them in the settings for each app (mail, people, calendar, messenger).

     

    No more phantom emails.

     

     

    • Proposed as answer by TrSpTi Monday, November 26, 2012 10:55 PM
    • Marked as answer by Niki Han Wednesday, November 28, 2012 2:19 AM
    Monday, November 26, 2012 10:54 PM

All replies

  • Hi,

    You can delete the massagers online, then sync Windows 8 Mail App.


    Niki Han

    TechNet Community Support

    Wednesday, November 7, 2012 8:38 AM
  • Having the same problem. But the messages don't show up online, so they're essentially synchronization 'ghosts'.
    Thursday, November 8, 2012 10:27 PM
  • Experiencing the same problem with the Mail app.  Wish Microsoft would patch this soon!! This is the sort of thing holding me back from migrating to Windows 8.
    Saturday, November 10, 2012 3:31 PM
  • Me too. The "No sender, No subject" mails aren't there online - only in the Windows 8 Mail app. And you can't delete them because the trash can disappears when you select one of them.

    -Doug

    Saturday, November 10, 2012 8:52 PM
  • Have you synced with Windows Mail App manually?

    I have no problem with my outlook account in Windows Mail App.


    Niki Han

    TechNet Community Support

    Tuesday, November 13, 2012 2:28 AM
  • Same here (me too)...I like Win 8...but this issue needs to be resolved

    I refuse to use the Mail App or IE10 in the UI Gui

    I have no problem in the desktop mode....except with Outlook

    I already did one refresh...it lasted a couple of days

    I am not going back to Win 7.....I like Win 8 but "come-on MS"....this is like the 1969 Palm issue that was fixed with a Palm patch

    I am convinced it is not a virus ...just a corrupted Win 8 App

    Me too. The "No sender, No subject" mails aren't there online - only in the Windows 8 Mail app. And you can't delete them because the trash can disappears when you select one of them.

    -Doug



    • Edited by abseh1 Tuesday, November 20, 2012 5:45 AM
    Tuesday, November 20, 2012 5:44 AM
  • Same for me. i currently have 3 eMails in this state, but i wont do a refresh!
    Tuesday, November 20, 2012 8:09 AM
  • I'm also having this issue.  It first appeared this morning when I opened my gmail.  I currently have 14 "No sender No Subject" emails in the list. 

    When clicked on, they open a blank page with only the "New" button in the top right.

    When right clicked on, they open bottom bar with options for "Sync" and "Pin to start".

    Sync does not change anything. 

    The other valid email in my inbox functions correctly. 

    Monday, November 26, 2012 8:46 PM
  • This is a problem with the mail app data store.  I deleted the mail folder from windows explorer (see path below) but that didn't help.  I deleted the entire windowscommunications... folder and that was bad (locked up windows).

     

    "C:\Users\ttirr_000\AppData\Local\Packages\microsoft.windowscommunicationsapps...

    \LocalState\Indexed\LiveComm\xxxxx...\xxxxx...\"

     

    I fixed this problem by uninstalling the mail app (includes people, calendar, messenger).  Be sure that your mail, appointments, etc. is backed up.  If you are syncing with outlook.com or Hotmail.com or exchange or an imap account you shouldn't have to worry.  You can just re-sync the accounts.  If you are using a pop server then you need to back up.

     

    Next just reinstall the mail, people, calendar, messenger app.  Your accounts should still be there you just need to configure them in the settings for each app (mail, people, calendar, messenger).

     

    No more phantom emails.

     

     

    • Proposed as answer by TrSpTi Monday, November 26, 2012 10:55 PM
    • Marked as answer by Niki Han Wednesday, November 28, 2012 2:19 AM
    Monday, November 26, 2012 10:54 PM
  • Move your cursor to the right hand of the screen while in the mail app.

    Choose Settings

    Options

    Turn Off Group Conversations

    That will resolve the issue until Microsoft fixes their crappy software.

    • Proposed as answer by Dan Wingfield Wednesday, December 19, 2012 7:44 PM
    Tuesday, December 11, 2012 12:15 AM
  • Thanks Chase5434 that's been annoying me for a while now.

    Wednesday, December 19, 2012 7:45 PM
  • Chase5434: Awesome... I didn't want to have to delete any apps to fix this... thanks!
    Friday, January 4, 2013 3:19 PM
  • Simply select these along with another genuine email you want to delete and use the Trash bin in that email.  They all go away, and the No Sender.... don't appear in trash either.
    • Proposed as answer by fraeFife Saturday, January 5, 2013 7:41 PM
    Saturday, January 5, 2013 7:41 PM
  • Simply select these along with another genuine email you want to delete and use the Trash bin in that email.  They all go away, and the No Sender.... don't appear in trash either.

    This worked for me.  Thanks!
    Thursday, January 10, 2013 12:44 AM
  • This is the true answer to prevent re-occurance until this is patched.

    Thank you Chase5434


    Saturday, January 26, 2013 1:13 PM
  • Yep, Chase5434 has the quick fix. Thank you.
    Sunday, March 3, 2013 9:17 PM
  • Chase5434's solution works except for one thing...my ghosts seem to be considered unread so my unread count is off in two of my email accounts.  Any idea how I can convince the system that the non-existent message was read?  Sounds crazy just asking the question but then it is a problem nonetheless.

    Tuesday, March 26, 2013 8:23 PM
  • I have the same issue as CCRRAR.  My count is wrong, but the phantom messages are not visible.  Evidently I'm having this same issue in my Junk folder as well.  I didn't see the need to pay to have someone tell me how to fix a free app.  Windows 8 is pretty disappointing - there a number of basic apps that don't work.  Netflix for example!

    Anyone have other solutions for the phantom email issue?? 

    Tuesday, April 30, 2013 5:32 PM