locked
Request Offering - Related Help Articles display in new tab RRS feed

  • Question

  • Hi,

    I link knowledge articles in my request offering, but I notice when I click the link for related help articles, the articles display on the same tab not in the new tab.

    I edit this code in SelfServicePortal\Views\Home\ServiceRequestDetails.cshtml

    I add target='_blank' but still not displaying in the new tab

     @if (KAs.Count != 0)
                {
                    @:<div class="fav_help_articles section">
                    @:<div class="row sub_heading">@Resources.SelfServicePortalResources.RelatedHelpArticles</div>
                    foreach (var KA in KAs)
                    {
                        Dictionary<string, object> item = KA as Dictionary<string, object>;
                        <a href='KnowledgeBase/Article/@item["ArticleId"]' target='_blank'>@item["Title"]</a>
                    }
                    @:</div>
                }

    Saturday, September 30, 2017 2:47 PM

Answers

  • You tried this as well?
    target="_blank"
    You cleared the IIS and Browser cache?

    Andreas Baumgarten | H&D International Group


    Sunday, October 1, 2017 6:55 AM
  • Hello,

    I am not familiar with coding, but from my sight, I would check whether the link below can be accessed directly: 

    'KnowledgeBase/Article/@item["ArticleId"]'

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 2, 2017 2:07 AM

All replies

  • You tried this as well?
    target="_blank"
    You cleared the IIS and Browser cache?

    Andreas Baumgarten | H&D International Group


    Sunday, October 1, 2017 6:55 AM
  • I tried this:

      <a href='KnowledgeBase/Article/@item["ArticleId"]' target='_blank'>@item["Title"]</a>
         
    and I also restart IIS, but still not opening in new tab. 

    Sunday, October 1, 2017 11:25 AM
  • Hello,

    I am not familiar with coding, but from my sight, I would check whether the link below can be accessed directly: 

    'KnowledgeBase/Article/@item["ArticleId"]'

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 2, 2017 2:07 AM
  • Me also I'm not familiar with this coding. But I will try to figure it out.

    Thank you

    Monday, October 2, 2017 5:00 AM