none
Problem runnin remote powershell using MIMWAL RRS feed

  • Question

  • I am running this kind of powershell using MIMWAL:

    powershell -version 3.0 "C:\Users\mimtestinstall\Desktop\azure\connect_to_azure.ps1"

    And I am getting this kind of error to MIMWAL Eventviewer:

    WAL (2.18.0318.0): 02/07/2019 15:06:44.1056: \mimtestinstall\Desktop\azure\connect_to_azure.ps1' is not recognized as the na
    me of a cmdlet, function, script file, or operable program. Check the spelling 
    of the name, or if a path was included, verify that the path is correct and try
     again.
    At line:1 char:1
    + C:\Users\mimtestinstall\Desktop\azure\connect_to_azure.ps1
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (C:\Users\mimtes...ct_to_azure.p 
       s1:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException
     
    
    
    
    At line:1 char:11
    + powershell <<<<  -version 3.0 'C:\Users\mimtestinstall\Desktop\azure\connect_to_azure.ps1'
    
    Can anyone explain what is the problem? The path is 100% correct.
    Thursday, February 7, 2019 1:22 PM

All replies

  • Seems like the script path is not accessible to the MIMService service account which would be the case if mimtestinstall in not your mimservice account.
    Tuesday, February 12, 2019 7:31 AM
    Owner
  • Well, not sure but I found a workaroud. When I store the scriptfile to under System32 folder the problem was fixed.

    Wednesday, February 13, 2019 11:44 AM