locked
"Errors were detected while saving (filename). Microsoft excel may be able to save the file by removing or repairing some features. To make the repairs in a new file click Continue. To cancel saving the file click Cancel. RRS feed

  • Question

  • Seems after we upgraded to Office 2016, some users are receiving this error in Excel and now also Power Point.

    If user opens an existing .xlsx file, makes changes, then goes to save the file, they receive this error.  same for when creating a new file, with the defaults set to .xlsx type file:

    "Errors were detected while saving (filename). Microsoft excel may be able to save the file by removing or repairing some features. To make the repairs in a new file click Continue. To cancel saving the file click Cancel.  clicking continue to do a repair does not work.  

    For now, a work around is to save it as a .xls type file.  Has anyone seen this issue and what is the fix.  Since it's now also happening with some Power Point files, i would assume its an Office issue, not just Excel.

    Friday, October 6, 2017 6:07 PM

All replies

  • Does this also occur if instead of simply using "Save", use "Save as" and enter a new filename and ensure correct file type is selected in "Save as Type" field.

    Regards, OssieMac

    Monday, October 9, 2017 12:53 AM
  • Hi,

    Do this problem appear in all Excel files?

    Do these files save in the same location?

    Please read this KB article and try the method of troubleshoot save problems in Excel:

    https://support.microsoft.com/en-in/help/271513/how-to-troubleshoot-errors-when-you-save-excel-workbooks

    Any updates please let me know and I'm glad to help you.


    Regards,
    Emi Zhang
    TechNet Community Support

    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 9, 2017 9:29 AM
  • when we do a save as and change it from an .xlsx to simply .xls, that works and it saves fine. 
    Monday, October 9, 2017 12:25 PM
  • it is happening on all her excel files.  they are saved in the same location from where they are opened from and/or created from. in he article you suggested, there is mention of this: The Transition Formula Evaluation feature is turned on in Excel.  it doesn't give state how to check this and/or turn it off.  this may be the reason, as all other avenues have been accounted for with no success.

    thanks for the help.

    Monday, October 9, 2017 12:29 PM
  • Solution

    If you encounter this error, you can save your data in a new Excel document or discard the changes and repair the original document:

    Save your data in a new Excel document

    To save changes you made to your document, copy the worksheets you changed to a new Excel document and save it.

    Repair your Excel document to avoid this error in the future

    You can repair your Excel file by deleting any Visual Basic for Applications (VBA) projects from your document. However, simply deleting them in the Visual Basic editor is not sufficient. you can also five a try to any excel repair tool like this one: https://www.stellarinfo.com/repair-excel-file.php
    Wednesday, October 11, 2017 9:46 AM
  • Is Microsoft going to come up with a fix/patch?  renaming and having to go in and remove and VBA is a burden.  if its a known issue, why not fix the issue?

    Thanks, Phil

    Thursday, October 12, 2017 12:31 PM
  • We have been dealing with this issues for the past few weeks. 

    On our part, we are using a cloud service called Owncloud. The issue arises when a user opens a file that's located  inside his Owncloud local folder. If the same file is copied elsewhere, the problem goes away. 

    We've been able to bypass the issue by mapping a network drive on that folder location. Ex. net use z:\ \\computername\c$\users\username\owncloud  and opening the file from the Z folder works fine on all file types.

    This is a weird problem but I know it is caused by either a Windows or Office update. The Owncloud desktop client is not the culprit here.

    Monday, October 30, 2017 4:28 PM
  • If I click cancel and then Save again, it seems to work ok.  I've had the problem for a while now.  I'm on the fast insider ring, so hopefully they figure this out.
    Sunday, January 7, 2018 2:23 PM
  • we will give that a try.

    Thanks, Phil

    Monday, January 8, 2018 1:55 PM
  • Having similar issues after a recent update. No change to virus protection. Suddenly started getting error messages about damage to existing .xlsx files and they could only be saved as .xls

    Files were on my local drive. No connections to other networks. No change to virus protection. Couldn't save them to other locations. Couldn't save them with different names. It is also happening to newer files created and saved as .xlsx

    Sounds like a bug created by the latest update to me - and it is interrupting work!

    Sunday, January 21, 2018 11:51 AM
  • Hi AimeeH,

    Is there any update on this? Have you found a solution? I encountered the same problem when swapping my laptop with a new one. It's seriously affecting my work. I'm savind now with .XLS

    Thanks,

    Chris

    Tuesday, February 6, 2018 7:32 PM
  • crazy thing, not sure a newer MS update fixed it, but my user said all of a sudden, its working correctly.  sorry to say, do not have an answer for you. Have you tried Zarifis suggestion above?

    Thanks, Phil

    Tuesday, February 6, 2018 8:18 PM
  • Does anyone found the solution.
    Is this is Microsoft failure or ...?
    Job affected drastically.


    Wednesday, February 28, 2018 6:11 PM
  • I think I have the same issue here.  I was just upgraded to Excel 2016, and Windows 10.  If I open an Excel file and make a change, then try to save it, I get the error.  I would say I get the error about 80 - 90% of the time.  When I open the same file on my old Windows 7 machine or my Mac, no issues at all.  This seems to be isolated to Windows 10 and Excel 2016.  It does look like renaming to .xls works, but I have hundreds of Excel files that I would need to rename.

    Please let me know if there is a fix other than re-imaging my laptop, or switching to a Mac (and using Excel for Mac).

    Thanks!!

    Saturday, March 3, 2018 1:52 AM
  • We are having the same problem with Excel 2016 and Windows 10 has this been fixed by Microsoft as this is causing us serious issues
    Thursday, May 3, 2018 3:01 PM
  • First announce about this very serious issue is from 06 October 2017, and until today (17 May 2018) Microsoft have done nothing at all, our computers (W10 and Office2016) are still affected from this bug, and they will do nothing. But, what did you expect, we are talking about Microsoft, they made bad software from ever. What I don't really understand is why all you folks prefer to pay Office, instead to install LibreOffice or Open Office which is more reliable than the Microsoft counterpart and they are also completely free and open source (this means that no one will spy on you and your text. Think about the fact that Microsoft made a program like that as a proprietary software!) Just, think seriously about it.






    Thursday, May 17, 2018 4:12 PM
  • Hi Everyone,

    I also got this error when I tried to create a new document by copying cells and a picture from an old file.

    When I deleted the picture that I had pasted into the new file, it allowed me to save it.

    Friday, May 25, 2018 6:32 AM
  • Check out to see if add-ins have been disabled - All I needed to do was re-activate add-ins and everything is working great - 
    Friday, July 6, 2018 7:45 PM
  • This didn't work for me. I re-activated add-inns, but still same problem.
    Wednesday, July 18, 2018 6:32 PM
  • I had the same problem with an Excel documents with Data Connections that I no longer used. Once I removed the connections and the sheets I used with them in the document, I would not let me save. Had to copy everything into a new document and save that one. 
    Tuesday, July 24, 2018 5:37 PM
  • I had the same problem and the same error message popped out. Following the suggestions I read here, I tried saving to .xls and it not only didn't save it but didn't even inform me it didn't do it. It just passed all the procedures without getting any notifications and I thought the file is saved to .xls.

    Next morning I tried to open my excel file, and it turned out it remained .xlsx and was corrupted and wouldn't open. I tried looking for recovery versions but couldn't find any. What I did next is I changed the default opening program for the file to Opera Internet Browser. Then I clicked double on it to open and a 'Save as' window popped out and I saved it again as it was to .xlsx. Then I double clicked on the file again (with Opera icon now) and it asked me which program to choose, and I chose Excel directly from its folder in Microsoft Office on the disk and it loaded the file.

    I'm not really tech-savvy and have no idea what I did but I have my tables and data back :) Since Microsofot does not really care about this bug, maybe such noobie solutions will help someone.


    • Edited by MajstorA Monday, August 13, 2018 11:04 AM
    Monday, August 13, 2018 11:02 AM
  • After some days of looking for solution to this problem, i finally found a solution from Dell Support and what i did was to apply the same solution to my problem and it worked like a charm. The solution is to change your regional language settings and make the default English US if you have it as any other language, the excel document will not save since it was initially created using a different regional Language setting. The solution worked for me on Windows10 pro and Office 2016 Pro Plus. I have had to change a laptop and almost condemned the 500GB SSD Hard disk that i bought and put in my laptop thinking the HDD was bad before i found this solution. Reference to where i got the clue is below on the dell website.

    https://www.dell.com/support/article/ng/en/ngbsdt1/sln308103/unable-to-save-workbook-in-microsoft-excel?lang=en

    • Proposed as answer by Oheng Thursday, October 25, 2018 7:29 AM
    Wednesday, October 24, 2018 9:37 AM
  • This worked for me! Thanks.

    I simply changes the regional language settings in Windows 10 to English (US) as default.

    Tuesday, November 20, 2018 8:19 AM
  • The can't save file problem just popped for me an hour ago - with the data I'm using to do my taxes.  

    • I created a new .xlsx file
    • Copied all tab by tab (don't remember how to do multiple tabs) - and I copied the cells, not the tab itself.
    • Saved it.  Saved just fine.

    • Went back to problem sheet.
    • saved it as .xls.
    • Saved normally.
    • Sounds like a very nasty bug in a recent Office 365 update.  And an old one.  And that you can't 'repair' it - not nice.




    Ron

    Saturday, February 9, 2019 7:15 AM
  • Is Microsoft going to come up with a fix/patch?  renaming and having to go in and remove and VBA is a burden.  if its a known issue, why not fix the issue?

    Thanks, Phil

    That's not how Micro$oft does things.

    You'll have to wait 5 to 7 years to perhaps having this dumb thing finally done as it was supposed in the beginning.

    Monday, February 11, 2019 11:12 AM
  • Exactly.  All the money goes into hype, and making changes for the sake of change, and creating new bugs in the name of progress!  Fixing bugs  - probably get you fired at MS!

    Ron

    Tuesday, February 12, 2019 5:48 AM
  • Thanks Oheng! I had a Windows 10 Pro PC with Office 2016 with this problem. When checking the language settings there were 4. Dutch (Netherlands), English (UK), English (USA), English (Europe). I deleted the Europe and UK versions and after that it was working again.

    • Proposed as answer by Dinkar.Govekar Monday, November 18, 2019 10:24 PM
    Tuesday, February 12, 2019 1:36 PM
  • Hi,

    This also worked initially - but the problem came back when going back to the original (recomended) language setting. 

    What i found is that graphs (both normal and pivot) are causing the issue. It is the old graphs created in older versions of Excel that are causing the saving error. When i deleted all graphs (not the data source - only the graphs) then it worked perfectly. 

    Hope this helps. 

    Tuesday, April 9, 2019 8:46 AM
  • I also changed my regional settings back to the one in which the Excel was created and this worked for me as well  
    Monday, May 6, 2019 2:17 PM
  • Regional Settings did not cure it for me. I can't believe this hasn't been fixed yet, this is not at all good!
    Tuesday, May 7, 2019 9:57 AM
  • Thanks so much Oheng, that was a lifesaver! Have same config as you.
    • Edited by AndreCH1 Friday, June 14, 2019 1:56 PM
    Friday, June 14, 2019 1:40 PM
  • Guys I had the same problem and I believe I created it unintentionally. Here's my hypothesis:

    I run Excel 365 on a Mac.

    I had several XLSX files open.

    I had to re-organize some folders in my finder (Explorer or File Manager) and so I renamed one folder that affected all the path into the files I had open in Excel. I think this is what triggered Excel not wanting to Save the File even changing the file name. The only thing that appeared to work was saving it as an XLS (instead of XLSX) and then save it back again as an XLSX. That worked although Excel gave me an Alert that I would lose "stuff" and so until I go in detail in the file and over time will I be able to assess if I lost any work/formulas/formats/charts.

    Wednesday, August 28, 2019 3:41 PM
  • Your solution worked like a charm - seems to be a bug within office 365

    Monday, November 18, 2019 10:23 PM
  • Thank you, changing the regional settings worked for me!
    Monday, December 9, 2019 1:09 PM
  • Thank you so much, this has worked for me
    Thursday, January 30, 2020 12:16 PM
  • It worked for my user's too as well.

    Friday, March 20, 2020 10:41 AM
  • But I can not understand the logic behind this.....
    Monday, July 27, 2020 6:48 PM