none
Project Server 2013 OLAP Cube build process keeps failing RRS feed

  • Question

  • Hi,

    I have an issue with building the OLAP Cube in Project Server 2013. After I activate the build process I see that an OLAP DB is being created under the Analysis Server but after a few minutes I receive the following error in the build proces status:

    ===== Het opbouwproces van de OLAP-database starten =====
    [23-4-2013 11:21] Bericht van verzoek tot kubus samenstellen is in de Project Server-wachtrij geplaatst
    ===== Servergebeurtenis-handler verifiëren en uitvoeren vóór het samenstellen =====
    [23-4-2013 11:21] De servergebeurtenisregistratie vóór het samenstellen verifiëren en uitvoeren
    ===== De structuur van de database en OLAP-database bepalen =====
    [23-4-2013 11:21] Initialiseren van het kubus samenstellen is gestart
    ===== Database en kubussen samenstellen =====
    [23-4-2013 11:21] De samenstellingssessie van de kubus is gestart
    ===== Servergebeurtenis-handler verifiëren en uitvoeren na het samenstellen =====
    [23-4-2013 11:21] De servergebeurtenisregistratie na het samenstellen verifiëren en uitvoeren
    ===== OLAP-database verwerken =====
    [23-4-2013 11:21] De sessie voor het verwerken van de OLAP-database is gestart
    ===== Het proces is voltooid =====
    [23-4-2013 11:22] Kan de OLAP-kubussen niet genereren. Fout: Fout bij het verwerken van de Analysis Services-database GEMAVEEN op de server ASVSQL001. Fout: OLE DB error: OLE DB or ODBC error: Login timeout expired; HYT00; A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.; 08001; Named Pipes Provider: Could not open a connection to SQL Server [53]. ; 08001.
    Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'Project Reporting data source', Name of 'Project Reporting data source'.
    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Project Owner', Name of 'Project Owner' was being processed.
    Server: The current operation was cancelled because another operation in the transaction failed.

    Retrying results in other dimensions that are being processed and return an error. Has anybody got an idea why this happens and how we can fix this issue?

    Thanks in advance.

    Frank


    Frank Jutte Winvision (http://www.winvision.nl) Project Manager / EPM Consultant

    Tuesday, April 23, 2013 9:29 AM

Answers

  • Hello Paul,

    We found the cause of the issue:
    1. The SQL alias wasn't set on the SQL server itself (SQL & SQL AS are running on the same server)

    After setting this we got Login failed for user 'Domain\AnalysisServerServiceAccount'

    2. Giving db_datareader permissions on the Project Server db for this account.

    After this we were able to Build the cube succesfully.

    Thanks for the help


    - Dennis | Netherlands | Blog | Twitter


    • Proposed as answer by fajjute Tuesday, May 7, 2013 1:35 PM
    • Marked as answer by FrankJutte Tuesday, May 7, 2013 1:36 PM
    • Edited by Expiscornovus Tuesday, May 7, 2013 1:52 PM
    Tuesday, May 7, 2013 1:32 PM

All replies

  • Hi there,

    Are you using a SQL Alias name for the Analysis server? If so, set  the SQL Alias on the SQL / SQL AS server using the 32 bit and 64 bit cliconfg.exe. Then retest.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Tuesday, April 23, 2013 11:36 AM
    Moderator
  • On the App Server, when I run cliconfg, I see that there is an alias that has been defined (called SharePoint). However, when I configure the cube with this alias I very soon receive an error that the server cannot be found (based on that alias).

    When using the SQL servername it seems that it can be found and that a database can be created. It is during the proces after creation that the procedure fails.

    Rgds, Frank

    Friday, April 26, 2013 2:14 PM
  • Ok things to check: Does the account running SQL analysis services have at least data reader access to the project database? Try with a new cube name Thanks Paul

    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Saturday, April 27, 2013 8:00 AM
    Moderator
  • I Checked those items: account has these rights in de project database (db_owner, DB_datareader, PSDataAccess, PSReportingSchemaAdmin, Public).

    Created a new cube and I can see that the cube is created under Analysis Server, unfortunately the build process keeps reporting Build Failure!

    Rgds, Frank

    Monday, April 29, 2013 11:49 AM
  • Hello Paul,

    We found the cause of the issue:
    1. The SQL alias wasn't set on the SQL server itself (SQL & SQL AS are running on the same server)

    After setting this we got Login failed for user 'Domain\AnalysisServerServiceAccount'

    2. Giving db_datareader permissions on the Project Server db for this account.

    After this we were able to Build the cube succesfully.

    Thanks for the help


    - Dennis | Netherlands | Blog | Twitter


    • Proposed as answer by fajjute Tuesday, May 7, 2013 1:35 PM
    • Marked as answer by FrankJutte Tuesday, May 7, 2013 1:36 PM
    • Edited by Expiscornovus Tuesday, May 7, 2013 1:52 PM
    Tuesday, May 7, 2013 1:32 PM
  • Hi Dennis,

    Could you please let me know how can I point to the same SQL alias?

    I already have both PWA Database and the Analysis Database on the same SQL Instance, but I still face the error you have above.


    Thursday, December 3, 2015 9:43 AM