locked
MAP 6.5.4226.0 - RPC Mapper crashing RRS feed

  • Question

  • So i'm trying to just take an inventory.  so far ive tried the active directory search & the sccm server search.. both result in the same thing.  RPC Mapper crashes, RPC service crashes, then all the services stop and the system im running the MAP tool on reboots itself.

    anyone else have this issue??

    Friday, December 23, 2011 7:39 PM

All replies

  • Sorry, my brain is still on holiday and I didn't read the title that says you're using MAP 6.5, so I had to delete my original response to this post which said to try MAP 6.5.

    MAP creates a worker thread that requests information from a target machine. The number of simultaneous worker threads created is dependent on CPU and Memory availability, but MAP has a cap that prevents it from maxing out a CPU and will throttle itself if it exceeds that cap. If MAP is installed on a machine with a lot of resources, it is possible for MAP to reach the maximum thread count of 300 for 64-bit and 200 for 32-bit. I have seen a similar situation occur in an environment where MAP was maxing out the threads and receiving a large number of RPC failure messages, which caused it to quickly spawn new threads. We are still investigating that and it sounds like you may have a similar problem. More information is always useful, so if you would like to help us gather more data, please send us an email at mapfdbk@microsoft.com and reference this post.

    As a temporary fix, try throttling MAP to see if this prevents the system from crashing. You can use the method below to adjust the throttle in MAP.

    1. Open  “Microsoft.AssessmentPlatform.UI.Console.exe.config” located in %Program Files%\Microsoft Assessment and Planning Toolkit\bin
    2. Add these 4 lines under the section “<appSettings>”
    <add key="Microsoft.AssessmentPlatform.InventoryEngine.InventoryService.DefaultMaxThreadsX86" value="52" />
    <add key="Microsoft.AssessmentPlatform.InventoryEngine.InventoryService.DefaultMaxThreads" value="52" />
    <add key="Microsoft.AssessmentPlatform.InventoryEngine.InventoryService.DefaultMinThreads" value="3" />
    <add key="Microsoft.AssessmentPlatform.InventoryEngine.InventoryService.MaxThreadsLowerBound" value="2" />
    3. The first line is only used if MAP is installed on a 32-bit machine, otherwise use the second line for setting the maximum number of machines that will be attempted to be inventoried simultaneously.
    4. Make sure MAP is not running when changing the values
    5. There are 2 internal threads that must run, so the minimum value is 3 (2 internal + 1 machine inventoried)
    The values listed will limit MAP to 50 simultaneous connections and thus cause the time needed to complete an inventory to increase. You can adjust the maximum value up or down as needed to maximize the performance while maintaining system stability. If this workaround does not solve the problem, please email us at the address provided above.

    Thanks


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 27, 2011 5:46 PM
  • I'll give this a try, thanks!
    Tuesday, January 3, 2012 9:29 PM
  • Any update on that? I am having the same issue. Randomly crashes...it getting really frustrating...

    ...

    Monday, December 17, 2012 10:45 PM
  • The problem seems to be related to a RPC bug and this hotfix has fixed the problem so far. http://support.microsoft.com/default.aspx?scid=kb;en-US;2401588


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. Please VOTE as HELPFUL if the post helps you. This can be beneficial to other community members reading the thread.

    Monday, December 17, 2012 11:00 PM
  • "The problem seems to be related to a RPC bug and this hotfix has fixed the problem so far. http://support.microsoft.com/default.aspx?scid=kb;en-US;2401588"


    This solution worked for our instance of MAP 8.0.5427.0 running on Windows 7 SP1 (64-bit) system.  We initially used the throttling setting above but after we got this hotfix installed we were then able to run the full domain/forest scans without issue.

    Thanks,

    David




    Tuesday, February 19, 2013 9:14 PM